Ask Your Question
0

Re-creating windows search filters [closed]

asked 2012-05-04 07:11:24 +0100

cosmos gravatar image

updated 2015-08-24 18:09:23 +0100

Alex Kemp gravatar image

Hello all,

on a couple of Windows 7 systems I had installed a component from http://www.ifiltershop.com/sofilter.html to have windows search indexing for opendocument files. Unfortunately this never worked as promised. In fact, it seemed to index only some file properties and not the actual content of each file. At the time I considered this a limitation.

Some days ago, after making a new installation of LibO 3.5.2 I happened to see that now Windows search could index also the content of odf files by using c:\program files\libreoffice 3.5\program\shlxthdl\ooofilt.dll

With these good news, I went back to my 2 win7 boxes, uninstalled the so-called standalone Staroffice/openoffice ifilter and even uninstalled/re-installed Libreoffice. Now's the strange part. On one of the system everything went fine, in windows search odf files got associated with ooofilt.dll for indexing. However, on the other system nothing happened! In indexing properties of windows search and for all ODF files it is stated that "No associated IFilter exists". Any ideas on what can be done to repair this?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 18:56:48.856137

2 Answers

Sort by » oldest newest most voted
0

answered 2012-05-04 07:23:15 +0100

cosmos gravatar image

updated 2012-05-04 07:29:22 +0100

Okay, seems like I was eager to open a case here without searching: this has been reported at http://en.libreofficeforum.org/node/338?destination=node%2F338&1b76_name=6a

There is also an open bug report for 3.5.x as Bug 47805. A workaround, as presented by the bug reporter is the following:

Manually registering the following dlls (win admin rights) solves the problem: regsvr32 "C:\Program Files (x86)\LibreOffice 3.5\program\shlxthdl\ooofilt_x64.dll" regsvr32 "C:\Program Files (x86)\LibreOffice 3.5\program\shlxthdl\shlxthdl_x64.dll"

edit flag offensive delete link more
0

answered 2012-06-10 19:10:40 +0100

cosmos gravatar image

This is a bug, that will be resolved at 3.5.1. See https://bugs.freedesktop.org/show_bug.cgi?id=47949

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-05-04 07:11:24 +0100

Seen: 942 times

Last updated: Jun 10 '12