Ask Your Question
0

How to write 0.10 without LO auto changing it 0.1?

asked 2020-04-13 14:19:41 +0200

Pranav Bbhattarai gravatar image

updated 2020-04-13 14:23:37 +0200

It's really annoying. How to stop this? I am trying hard to write 0.10 but it's not working at all.

Problem I am trying to solve.

   Version: 6.3.5.2
   Build ID: 1:6.3.5-0ubuntu0.19.10.1
   CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
   Locale: ne-NP (en_US.UTF-8); UI-Language: en-US
   Calc: threaded
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2020-04-13 14:38:13 +0200

Opaque gravatar image

updated 2020-04-13 14:44:45 +0200

Hello,

  • disable Table -> [ ] Number Recognition --or--
  • Select cells in column Probability and Table -> Number Format... and format as Category Number using Decimal places: 2 (see screenshot)

image description

Hope that helps.

If the answer helped to solve your problem, please click the check mark (✔) next to the answer.

edit flag offensive delete link more

Comments

@Opaque It did not worked. I selected all contents of that column and went to Top menu option where I can see Table. I went there and unselected Number Recognition. Tried to add a zero like 0.10 but it autocorrected to 0.1.

Looks like I have to delete all the numbers and rewrite 0.10, which seems to be working. Weird.

New data are responding as I turned off Number Recognition. But old data is not. (please make a feature request to LO devs & make old data to follow user's preferences.)

Thanks a lot. Problem solved.

Update: Even after deleting entire row contents, it didn't work. I think I have to delete entire column. More weird.

Pranav Bbhattarai gravatar imagePranav Bbhattarai ( 2020-04-13 14:57:32 +0200 )edit

(please make a feature request to LO devs & make old data to follow user's preferences.)

That's up to you, but I'm pretty sure that they won't follow such requests, since this would imply to change existing documents based on preferences on opening, which may not have been intended by the author of an document. That's definitely a no-go.

Opaque gravatar imageOpaque ( 2020-04-13 16:23:28 +0200 )edit

If I understand correctly, it seems that you have not yet tried the second suggestion by @Opaque to format the numbers in the column as explicitly having two decimal places. (See red box above.) When you do that, LibreOffice automatically adds zeroes at the end of the number to give each of the numbers two decimal places. You should not have to add anything.

ve3oat gravatar imageve3oat ( 2020-04-13 16:40:33 +0200 )edit

@Opaque You are understanding it in the wrong way. When a user, while writing, prefers to write a heading in a bold letter in some topics doesn't mean he is asking for LO Writer to change the entire document in the bold letter, does it? You are making it sounds like, if a user writes in DejaVu fonts then he can't change fonts anymore. What's done is done? He should have thought about it before writing the document. Now if he wants to change fonts, he has to delete everything and write from the beginning! This is bad. Someone needs to address this.

Pranav Bbhattarai gravatar imagePranav Bbhattarai ( 2020-04-13 16:44:25 +0200 )edit

@ve3oat That's the new answer. He modified it, I will look into that too. Thanks.

Pranav Bbhattarai gravatar imagePranav Bbhattarai ( 2020-04-13 16:47:03 +0200 )edit

@Pranav Bbhattarai - I did not update my answer right now, it was that way 2 hours ago. It's you not reading the --or-- and I did understand you that you want preferences changing document content and changing a font to bold is not changing a preference but direct formatting and as such editing a document, which I have not been talking about.

Opaque gravatar imageOpaque ( 2020-04-13 16:51:52 +0200 )edit

@Opaque Anyway, thanks a lot. And you are right about me ignoring --or-- portion because I thought "normally" the first method should have worked without having to go through the second method. What's the point of giving the first method if it doesn't applicable selected region.

(But my small feature request seems legit. It's a very small thing but the really important thing for being user-friendly software.)

Don't comment after this. :-D

Pranav Bbhattarai gravatar imagePranav Bbhattarai ( 2020-04-13 17:08:43 +0200 )edit

@Opaque:

The problem was that OP already had that cell formatted as number - that happened because of the number recognition had previously already detected the number, and formatted the cell explicitly. So the data entered there was considered numeric regardless of the number recognition setting.

When changing the setting, it will work for any cell formatted as text - prevent recognizing that text as non-text, and additionally auto-formatting the result.

Mike Kaganski gravatar imageMike Kaganski ( 2020-04-14 10:52:42 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-04-13 14:19:41 +0200

Seen: 50 times

Last updated: Apr 13