Ask Your Question
0

When copy/pasting LORD is changed to Lord.

asked 2020-04-16 18:12:59 +0100

jbbacher gravatar image

updated 2020-04-17 21:02:39 +0100

Jim K gravatar image

Is there a setting to allow it to remain in all caps? In the example below the 1st use of the word "LORD" has the class=divineName. The 2nd use should be “Lord” as it is not the divineName.

Code submitted by OP:

 <html>
    <head>
       <meta http-equiv="content-type" content="text/html; charset=utf-8">
       <style type="text/css">
          <!-- A { text-decoration:none } *[dir=rtl] { text-align: right; } .transChangeSupplied { font-style: italic; } -->
       </style>
    </head>
    <body>
       (Psalms 16:2)
       <span class="line indent0">I say to the <span class="divineName">Lord</span>,
       “You are my Lord;</span>
       <br />
       <span class="line indent0">I have no good apart from you.”</span>
       <br />
       <br />
     </body>
 </html>

Edited by ajlittoz: question description is HTML code. If it is not indented correctly, it is interpreted by the question engine as being the formatting to apply, making the question totally obscure.

edit retag flag offensive close merge delete

Comments

Maybe I don't understand the issue. I typed LORD into this comment, copied it into my clipboard and pasted it into my document and it is still in all caps.

habadeer gravatar imagehabadeer ( 2020-04-16 19:02:52 +0100 )edit

Try putting <span class="divineName">LORD</span>in the first mention and leave it out after that and see if that works

JEDIMASTER gravatar imageJEDIMASTER ( 2020-04-17 12:58:19 +0100 )edit

Please explain the relation between this HTML code snippet and what you are trying to do. In particular, tell us which Writer mode you are using: "standard" text document or HTML document composer?

Don't forget to mention your OS and LO version.

Do that by clicking on the edit link below your question and position the cursor after my remark about formatting your question.

You force a line break by entering twice Return: this leaves an intermediate empty line in the green entry box but it is correctly translated when you hit Save.

While you're at it, edit the title to make it shorter. Most of what is presently there should be moved to the question description.

ajlittoz gravatar imageajlittoz ( 2020-04-17 14:35:18 +0100 )edit

Moved most of the title into the question body. See guidelines for asking.

Jim K gravatar imageJim K ( 2020-04-17 21:05:08 +0100 )edit

When you copy/paste the troublesome text, do you also copy/paste the CSS style sheet specification for span class="divineName"? Otherwise, how is anyone to know that

<span class="divineName">Lord</span>

is supposed to result in LORD?

ve3oat gravatar imageve3oat ( 2020-04-17 21:13:13 +0100 )edit

As given, your html code is incomplete, as it lacks an href declaration of the presumed CSS style sheet (style.css), as in

<head>
...
<link rel="stylesheet" href="style.css" />
</head>

Maybe that is part of the problem as well.

But none of this has anything to do with LibreOffice.

ve3oat gravatar imageve3oat ( 2020-04-17 21:49:55 +0100 )edit

Thanks ve3oat. I copied this from Xiphos Bible Software. I'll make them aware of the problem.

jbbacher gravatar imagejbbacher ( 2020-04-20 15:06:28 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-04-18 00:22:53 +0100

flywire gravatar image

updated 2020-04-18 00:24:54 +0100

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-04-16 18:12:59 +0100

Seen: 116 times

Last updated: Apr 18 '20