We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

Libreoffice Writer does not continue in chapter numbering

asked 2020-04-20 00:08:52 +0200

janchytry gravatar image

updated 2020-08-08 18:55:56 +0200

Alex Kemp gravatar image

Hey, I guess I have a specific problem in Write I could not find a solution for. I will describe it naively, hoping someone can help me figure it out or spot a bug. Here's the problem:

I set chapter numbering based on Heading levels in Tools -> Chapter Numbering... for the whole document as such:

1

1.1

1.1.1 etc

Now I:

  1. selected Heading 1 style, turned on numbering with Toggle Numbered List and wrote something
  2. entered a new line, selected Heading 2 style, turned on numbering with Toggle Numbered List and wrote something
  3. entered a new line, selected Text Body style, wrote some text and a bulleted list
  4. entered a new line, selected Heading 1 style, turned on numbering with Toggle Numbered List which caused reverting the numbering to 1. Of course, it should be 2, so I right-clicked -> Continue Previous Numbering, which caused the continuation of the bulleted list from the Text Body style above.

I cannot seem to find an option to accurately continue the numbering of the Heading 1 even though it was set globally in Chapter numbering...

Thanks!

edit retag flag offensive close merge delete

Comments

Thanks for the answer!

I thought Chapter Numbering and Toggle Number List would be conflicting attributes, and would happily use Chapter Numbering only.

If it worked.

I think I expressed myself incorrectly before. When I select Heading 1 style later after the bulleted list, Writer restarts it by default to 1, careless of previous Heading n's. There is no continuation I'd expect as I had done my preliminary settings in Chapter Numbering.

janchytry gravatar imagejanchytry ( 2020-04-20 09:37:40 +0200 )edit

This is no solution to your problem. Move it either as an edit to your question or as a comment under my answer.

If it still doesn't work, please attach a reduced version of your file (3 pages max) to you question (edit, then use the paperclip tool) so that I can anlyse it. If needed anonymise your data.

ajlittoz gravatar imageajlittoz ( 2020-04-20 10:58:15 +0200 )edit

Are you by chance using DOC(X)?

Mike Kaganski gravatar imageMike Kaganski ( 2020-04-22 14:50:23 +0200 )edit

Yes, I do. Do you think, it would be a compatibility issue?

janchytry gravatar imagejanchytry ( 2020-04-23 13:09:00 +0200 )edit

Definitely. There's no chapter numbering in Word, and the conversion of this between the Writer's feature and Word format is imperfect. See tdf#130446.

Mike Kaganski gravatar imageMike Kaganski ( 2020-04-23 13:11:22 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-04-20 08:37:01 +0200

ajlittoz gravatar image

Chapter numbering and Toggle Numbered List are incompatible and conflicting attributes. With the list button, you create lists, which is a contiguous sequence of numbered items (this is simplified for a quick explanation). When you enter your second Heading 1 and turn on numbered list mode, you create a second list which has its own sequence of numbers as you would expect for different lists.

You were right in setting properties in Tools>Chapter Numbering. They apply to the Heading n family of styles. There nothing more to do. Just use the Heading n styles and your chapters will get numbered.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2020-04-20 00:08:52 +0200

Seen: 292 times

Last updated: Apr 20 '20