spellcheck and footnote

asked 2020-04-20 11:30:32 +0100

giors gravatar image

updated 2020-08-02 22:55:40 +0100

Alex Kemp gravatar image

whenever I launch the spellcheck (F7), closing the dialog, makes footnotes disappear: instead, there is just a number in the text.

Document was written 10 years ago but is currently saved in .odt format (very important to me and quite large).

I have tried to erase direct format, copy-paste in a new document without format (and manually adding the footnotes) but nothing solved the problem. Also changed the language and the dictionary...

Using 6.4.3.2 version on arch linux.

Thanks for your help

edit retag flag offensive close merge delete

Comments

spellcheck also erase italic.

giors gravatar imagegiors ( 2020-04-20 11:43:00 +0100 )edit

also noticed that it changes the language. Document is written with multiple languages: main language is Spanish but it has latin expressions. Spellcheck change latin into spanish (don't know why)

giors gravatar imagegiors ( 2020-04-20 11:54:48 +0100 )edit

especially when a footnote is located just after a word that needs be corrected, it disappears!

giors gravatar imagegiors ( 2020-04-20 12:04:44 +0100 )edit

definitely when a footnote anchor follows a spelling mistake, it seems that spellcheck considers the footnote also a mistake and it corrects it deleting the footnote and converting its anchor in a number. Any work-around?

giors gravatar imagegiors ( 2020-04-20 18:33:11 +0100 )edit