spellcheck and footnote

whenever I launch the spellcheck (F7), closing the dialog, makes footnotes disappear: instead, there is just a number in the text.

Document was written 10 years ago but is currently saved in .odt format (very important to me and quite large).

I have tried to erase direct format, copy-paste in a new document without format (and manually adding the footnotes) but nothing solved the problem. Also changed the language and the dictionary…

Using version on arch linux.

Thanks for your help

spellcheck also erase italic.

also noticed that it changes the language. Document is written with multiple languages: main language is Spanish but it has latin expressions. Spellcheck change latin into spanish (don’t know why)

especially when a footnote is located just after a word that needs be corrected, it disappears!

definitely when a footnote anchor follows a spelling mistake, it seems that spellcheck considers the footnote also a mistake and it corrects it deleting the footnote and converting its anchor in a number. Any work-around?