We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

XLS files opening in Writer [closed]

asked 2013-10-19 00:16:59 +0200

IsenMike gravatar image

updated 2021-06-21 14:10:04 +0200

Alex Kemp gravatar image

I just updated to the newest version of Libre Office. Now whenever I open a .xls file from Finder, Libre Office tries to open it in Writer.

The only way I can seem to get these files to open correctly is to go into Libre Office, choose "Open...," navigate to the file, and select "Microsoft Excel 97/2000/XP/2003" as the File Type.

Is there some way to get Libre Office to default to this File Type for the .xls file extension? This was never a problem before I updated, and it's kind of a huge pain.

EDIT: Version 4.1.2.3 Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2021-06-21 14:10:22.269776

Comments

"latest version" is not a sufficient information. Thus please let us know which version you are using. Look into About LibreOffice

ROSt52 gravatar imageROSt52 ( 2013-10-19 06:02:56 +0200 )edit

Version 4.1.2.3 Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38

IsenMike gravatar imageIsenMike ( 2013-10-21 16:14:19 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-10-22 11:18:12 +0200

Zeki Bildirici gravatar image

Hi,

Right click an xls file, select Open With... - Set Default Programe(or something like that) select LibreOffice Calc or Microsoft Excel and clich use this programe as default.(Similar in Windows and Linux desktop enviroments).

If problem persists, try to reset the user profile as instructed here: https://wiki.documentfoundation.org/Documentation/UserProfile#Resetting_the_User-Profile but be carefull for the notifications like your templates and other stuff may be deleted have a copy then...

If this not solves, you shold fill a bug report at https://www.libreoffice.org/get-help/bug/ . Btw i think if you are sure that upgrade caused this, you should better fill a bug report too. Don't forget to write the previous version.

Best regards, Zeki

edit flag offensive delete link more

Comments

I have essentially the same problem. Downloading a file from Santander I could open it in 3xxx but in both 4.2 and 4.3 versions the files get thrown into Writer where they appear in xml format. That two successive versions of LO don't open them correctly showOpening them in a text ed (kate) shows that this is the format supplied. There must be a setting in LO which I cannot find to make the xml files open correctly. Gnumeric opens them happily and will then save them as the old binary format.

lauriejb2006 gravatar imagelauriejb2006 ( 2014-09-05 22:04:02 +0200 )edit
0

answered 2013-10-22 13:21:28 +0200

m.a.riosv gravatar image

There is a reported bug about this issue: FILEOPEN: Excel 2 sheet (xls) opens in writer

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-10-19 00:16:59 +0200

Seen: 5,137 times

Last updated: Oct 22 '13