xls files opening in Writer, not Calc

LibreOffic Calc Version:, Build ID: 430m0(Build:2)

Xubuntu 14.04 64-bit

Hello - I am having what seems to be an identical problem to that reported here: xls files opening in writer The spreadsheets I’m having trouble opening are also from Santander and Gnumeric does seem to be able to open them as intended.

Following the bug reports that are cited in that question thread suggests that they have been resolved, however I’m still seeing the problem. It’s entirely likely that I’m not doing something necessary to make it work for lack of understanding - I’m using the ‘still’ version of LO if that might be an issue?

I’d attach an example of a problem file, however it has bank information that I wouldn’t want to share. If it would be helpful I can check whether the problem can be replicated when I’ve stripped out the private information on a Windows install tomorrow.

Thanks in advance, Sarah

That is likely not a true xls file, but they named it xls. So Excel tries to open it, using one of its import filters. Please look at the file with a simple editor and post the beginning, even if it is cryptic to you.

Another approach is to not double click the file, but open it via file > open and thereby choose an import filter of the spreadsheet section. “Text CSV” or “Web page query” are promising. First select the file, then the filter.

Thanks so much, Regina.

The “Text CSV” option did open in Calc instead of Writer, however it was still a mess. I’ve just tried the “Web page query” option - works beautifully! Everything formatted as intended and arranged into the columns I recognise.

Without wanting to sound greedy, would there be something I can do to avoid having to scroll through the list of file-types before opening these “.xls” files in future? (I can post html code in a new comment if still of interest?

There is a good explanation and solution to the Santander XLS download problem in question 15858. I tried “Web Page Query” and it works but I agree it is a lot of work to get around the problem. See: Problem reading xls file