Ask Your Question
2

keyboard shortcuts on Libreoffice 4.1 won't act when I change the language [closed]

asked 2013-10-22 21:37:49 +0100

Odysseus gravatar image

updated 2015-08-27 13:20:52 +0100

Alex Kemp gravatar image

I am an Iranian journalist who use Ubuntu 13.10 and after upgrade my OS, I've found that libreoffice's keyboard shortcuts won't work when I change keyboard layout to "Persian". for example when i press Ctrl+C or Ctrl+V etc. nothing happens. Any idea plz?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-22 15:23:17.259124

4 Answers

Sort by » oldest newest most voted
1

answered 2013-11-14 19:08:27 +0100

edit flag offensive delete link more

Comments

So - known a LONG time, but still not fixed. Is there a reason? Sometimes even an explanation helps the patience levels. :) Thanks!

David gravatar imageDavid ( 2013-11-14 21:04:02 +0100 )edit
1

A read through the bug indicates it is largely related to Gnome 3 (although one poor soul on MacOS reports the same). The dire recent history of Gnome 3 could be at the root of the delay i.e., the change from v2 -> v3 made a lot of people unhappy. It could also be that updating the packages libreoffice-gtk and libreoffice-gnome requires a lot of work, due the extensive changes from Gnome v2 -> v3.

oweng gravatar imageoweng ( 2013-11-14 23:25:05 +0100 )edit

@oweng - thanks - and just to be clear, this isn't a bug I suffer from (thankfully!). I just checked in fact (on this machine, Mint 13 LTS + LibO 4.0.4.2) following the reproduce-bug-steps from the Bugzilla reports, and everything worked perfectly. Feel bad for those afflicted by this one, though.

David gravatar imageDavid ( 2013-11-15 00:27:23 +0100 )edit
1
manj_k gravatar imagemanj_k ( 2013-11-28 23:41:11 +0100 )edit
0

answered 2013-10-23 00:48:39 +0100

oweng gravatar image

Does changing the Locale setting (Tools > Options... > Language Settings > Languages) help? There is also the option under Tools > Customize... > Keyboard tab > for loading and saving keyboard layouts. I am not certain to what extent this latter facility relates to the operating system keyboard setting.

edit flag offensive delete link more
0

answered 2014-03-05 23:38:10 +0100

After months of switching layouts and banging my head against this bug, I thought I should check LibreOffice settings (I'm using 4.1.5.3 now). What figures? I did find something. And in just a few clicks.

This is not a bug! It's simply a matter of configuration.

For the regular keyboard shortcuts (like Ctrl+C, Ctrl+V, etc.) to remain operational in LibreOffice applications while using a non-latin keyboard layout (like Greek or Russian), go to Tools -> Options -> Language Settings -> Languages, check the Ignore system input language option, save, and Bob's your uncle.

Hope this helps.

Cheers!

PS Technically, though, shortcuts still remain language-dependent. This means if you enable this option, you will have to set your document languages manually.

edit flag offensive delete link more

Comments

Didn't work for me, unfortunately :(

Nicolas Ivanov gravatar imageNicolas Ivanov ( 2014-05-12 10:01:36 +0100 )edit
0

answered 2014-05-12 10:13:17 +0100

Try downloading LibreOffice 4.2.4 from the official site: http://www.libreoffice.org/download/l...

It fixed the problem for me in Ubuntu 13.10

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-10-22 21:37:49 +0100

Seen: 2,912 times

Last updated: May 12 '14