Keyboard shortcuts on Libreoffice 4.1 won't act when I change the language

I am an Iranian journalist who use Ubuntu 13.10 and after upgrade my OS, I’ve found that libreoffice’s keyboard shortcuts won’t work when I change keyboard layout to “Persian”. for example when i press Ctrl+C or Ctrl+V etc. nothing happens.
Any idea plz?

This is

So - known a LONG time, but still not fixed. Is there a reason? Sometimes even an explanation helps the patience levels. :slight_smile: Thanks!

A read through the bug indicates it is largely related to Gnome 3 (although one poor soul on MacOS reports the same). The dire recent history of Gnome 3 could be at the root of the delay i.e., the change from v2 → v3 made a lot of people unhappy. It could also be that updating the packages libreoffice-gtk and libreoffice-gnome requires a lot of work, due the extensive changes from Gnome v2 → v3.

@oweng - thanks - and just to be clear, this isn’t a bug I suffer from (thankfully!). I just checked in fact (on this machine, Mint 13 LTS + LibO following the reproduce-bug-steps from the Bugzilla reports, and everything worked perfectly. Feel bad for those afflicted by this one, though.

Bug 41169 - All hotkeys are language dependent, don’t work in non-Latin keyboard layout


LibreOffice 4.1.4 / 4.2.0

Does changing the Locale setting (Tools > Options… > Language Settings > Languages) help? There is also the option under Tools > Customize… > Keyboard tab > for loading and saving keyboard layouts. I am not certain to what extent this latter facility relates to the operating system keyboard setting.

After months of switching layouts and banging my head against this bug, I thought I should check LibreOffice settings (I’m using now). What figures? I did find something. And in just a few clicks.

This is not a bug! It’s simply a matter of configuration.

For the regular keyboard shortcuts (like Ctrl+C, Ctrl+V, etc.) to remain operational in LibreOffice applications while using a non-latin keyboard layout (like Greek or Russian), go to Tools → Options → Language Settings → Languages, check the Ignore system input language option, save, and Bob’s your uncle.

Hope this helps.


Technically, though, shortcuts still remain language-dependent. This means if you enable this option, you will have to set your document languages manually.

Didn’t work for me, unfortunately :frowning:

Try downloading LibreOffice 4.2.4 from the official site:

It fixed the problem for me in Ubuntu 13.10