Ask Your Question
0

Why can't I get past the 'address block' step in the Mail Merge wizard on Ubuntu? [closed]

asked 2013-10-23 11:27:48 +0200

pierre-e-delman gravatar image

updated 2015-09-01 21:08:20 +0200

Alex Kemp gravatar image

Hi there,

My pb looks the same as someone else's but was not solved. Here is what I did :

  • I have address entries in a spreadsheet that I saved in .csv and .ods formats (just to try them both).
  • The first line has the names of the fields.
  • I have placed the name of the fields in <brackets> in the .odt document that I intend to merge with the adresses.
  • From that document, I went to Tools>Mailing Wizard.
  • I am "using the actual document" (Next) It's a "Letter" (Next).
  • Then I have to insert an address block, so I click on the button to "select an address list" and I choose the spreadsheet.

Now, whatever the format or notwithstanding the fact that I cleaned the spreadsheet from anything that will not be merged, the Next button is grey and cannot be depressed (unlike me :-))).

I use Version: 4.1.2.3 Build ID: 410m0(Build:3) with Ubuntu 13.10

What do I do wrong ? Can someone help please ?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-29 16:51:38.107505

Comments

1

I don't have an answer but I do have the same problem as you. I've tried everything imaginable and have never been able to get passed that third screen in the wizard. The Next button is always greyed out and it's impossible to get to step four. I assume this is just a bug in Libre Office. If it was intentionally, surely they'd provide a human-readable error message explaining WHY we are not able to proceed to step four.

Steevithak gravatar imageSteevithak ( 2013-12-07 20:40:49 +0200 )edit

I have the same problem Ver 4.2.1 for Windows XP. Mail Merge code is poorly thought out and dysfunctional. Knowing this, don't waste as much time as I have trying to get it to work. The only way I see to delete all the "Created" lists is to remove/reinstall. I sure hope OL can put out a version where this feature works like this product should. I made the requested $$ donation before I ran into this problem ... now I have to switch to another product.

LOtester gravatar imageLOtester ( 2014-03-06 08:50:05 +0200 )edit

@LOtester, did the solution found by @pierre-e-delman not work for you? @Steevithak: Did you see the linked question and answer?

bencomp gravatar imagebencomp ( 2014-07-12 17:44:13 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-10-28 09:40:41 +0200

pierre-e-delman gravatar image

And the answer is : DON'T FORGET TO INSTALL THE LO DATABASE. IT DOES NOT COME FIRST HAND WITH THE UBUNTU PACKAGE !

edit flag offensive delete link more

Comments

That is a proper shout of relief :) Could you just change the capitalisation and add a few words like "LibreOffice needs the Base application to handle the data source connection"? Thanks.

bencomp gravatar imagebencomp ( 2014-01-05 16:25:45 +0200 )edit

This does not solve it for me.

artfulrobot gravatar imageartfulrobot ( 2016-08-30 11:26:03 +0200 )edit

Pierre's advice worked for me (Ubuntu 14). Agree with bencomp - some details would be helpful.

Here's what I did to get it to work: - Ran the following from the terminal: sudo apt-get install libreoffice-base

Prior to that, to be sure there were no issues with my spreadsheet (osd file), I had created a 1 record address list with the "Create" button on the "Select Address List" in the Mail Merge Wizard. I then copied those field names to my spread sheet.

geoloo gravatar imagegeoloo ( 2017-04-01 14:57:01 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-10-23 11:27:48 +0200

Seen: 2,251 times

Last updated: Jul 12 '14