Why can't I get past the 'address block' step in the Mail Merge wizard on Ubuntu?

Hi there,

My pb looks the same as someone else’s but was not solved.
Here is what I did :

  • I have address entries in a
    spreadsheet that I saved in .csv and
    .ods formats (just to try them both).
  • The first line has the names of the
  • I have placed the name of the
    fields in in the .odt
    document that I intend to merge with
    the adresses.
  • From that document, I went to
    Tools>Mailing Wizard.
  • I am “using the
    actual document” (Next) It’s a
    “Letter” (Next).
  • Then I have to
    insert an address block, so I click
    on the button to “select an address
    list” and I choose the spreadsheet.

Now, whatever the format or notwithstanding the fact that I cleaned the spreadsheet from anything that will not be merged, the Next button is grey and cannot be depressed (unlike me :-))).

I use Version: Build ID: 410m0(Build:3) with Ubuntu 13.10

What do I do wrong ? Can someone help please ?

I don’t have an answer but I do have the same problem as you. I’ve tried everything imaginable and have never been able to get passed that third screen in the wizard. The Next button is always greyed out and it’s impossible to get to step four. I assume this is just a bug in Libre Office. If it was intentionally, surely they’d provide a human-readable error message explaining WHY we are not able to proceed to step four.

I have the same problem Ver 4.2.1 for Windows XP. Mail Merge code is poorly thought out and dysfunctional. Knowing this, don’t waste as much time as I have trying to get it to work. The only way I see to delete all the “Created” lists is to remove/reinstall. I sure hope OL can put out a version where this feature works like this product should. I made the requested $$ donation before I ran into this problem … now I have to switch to another product.

@LOtester, did the solution found by @pierre-e-delman not work for you? @Steevithak: Did you see the linked question and answer?


That is a proper shout of relief :slight_smile: Could you just change the capitalisation and add a few words like “LibreOffice needs the Base application to handle the data source connection”? Thanks.

This does not solve it for me.

Pierre’s advice worked for me (Ubuntu 14). Agree with bencomp - some details would be helpful.

Here’s what I did to get it to work:

  • Ran the following from the terminal: sudo apt-get install libreoffice-base

Prior to that, to be sure there were no issues with my spreadsheet (osd file), I had created a 1 record address list with the “Create” button on the “Select Address List” in the Mail Merge Wizard. I then copied those field names to my spread sheet.

I can confirm the solution for Debian/stretch (stretch-backports):

sudo apt install libreoffice-base


sudo apt install -t stretch-backports libreoffice-base

did the trick for me.

(I am currently unable to up vote the question, the answer nor the comment but thanks to @pierre-e-delman and @geoloo for asking and answering the question.)