We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

Default zoom level for opening a Word document

asked 2020-05-13 18:00:50 +0200

smurf gravatar image

updated 2020-07-22 14:30:09 +0200

Alex Kemp gravatar image

Whenever I open a Word document with Libreoffice (version 6.4.3.2 for Mac) it defaults to a zoom level of 150%. That's way too big for my screen, so I have to change the zoom to 75%. Is there a way to make it default to 75%?

NB per https://ask.libreoffice.org/en/question/141315/default-zoom-level/ I have already saved a template at 75% and disabled "Load user-specific settings with document". That did not solve the problem, documents still open at 150%. (Though when I create a new document, the default zoom of that is now 75%. So I guess the template only effects new documents, not pre-existing ones.)

edit retag flag offensive close merge delete

Comments

Word document

Do you really mean .docx documents?

Opaque gravatar imageOpaque ( 2020-05-13 18:13:31 +0200 )edit

Zoom is (unfortunately?) not a user-specific setting. Thus it's unaffected by that checkbox.

Mike Kaganski gravatar imageMike Kaganski ( 2020-05-14 08:37:55 +0200 )edit

Yes, I mean .docx documents (sent to me by others, created with MS Word).

smurf gravatar imagesmurf ( 2020-05-14 17:08:50 +0200 )edit

Ok - can't comment how native .docx documents store the zoom level (Got no MS Office to create my own .docx document). But I'd assume that it is stored within the document as well and hence it is beyond your influence how it opens.

Opaque gravatar imageOpaque ( 2020-05-14 17:13:52 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-05-13 18:11:54 +0200

Opaque gravatar image

updated 2020-05-14 11:26:13 +0200

Hello,

talking about ODF format (not .docx etc. formats) the zoom level is a document property stored in file settings.xml of the .odt zip container and looks like this:

<config:config-item config:name="ZoomFactor" config:type="short">160</config:config-item>

Hence you need to

  • Open a file
  • Change the zoom factor
  • Save the file

to get that to a new zoom factor on opening.

edit flag offensive delete link more

Comments

2

s/xlm/xml/

Mike Kaganski gravatar imageMike Kaganski ( 2020-05-14 08:34:30 +0200 )edit

..... done

Opaque gravatar imageOpaque ( 2020-05-14 11:26:40 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-05-13 18:00:50 +0200

Seen: 584 times

Last updated: May 14 '20