Ask Your Question
0

How to increase resolution of figures exported from Draw

asked 2020-07-03 08:27:17 +0200

pincopallino gravatar image

Greetings,

when I export as TIFF figures from Draw I get insufficient resolution, often 72 dpi. I do not find any option to increase the resolution, but I need at least 300 dpi. Is there a workaround, or perhaps an option I have missed?

Thank you in advance for your help.

edit retag flag offensive close merge delete

Comments

Since TIFF is a bitmap format, have a look at Tools>Options, LibreOffice>Print. There are two modes Printer and Print to File. You may need to try both of them. Adjust the output resolution in Reduce Bitmaps section.

If this works, I'll make my comment an answer.

ajlittoz gravatar imageajlittoz ( 2020-07-03 09:15:37 +0200 )edit

The easiest is Export... , choose PNG (and tick Selection I presume). When you click Save you are taken to a new dialog where you can set resolution. Before you set the resolution take a note of the size because increasing resolution decreases size so you after you set to 300 dpi got into one of the sizes and type in the original value, the other will change to match, OK out. You can now convert your your png to a TIFF in a graphics editor. I don't know why the TIFF export doesn't have the sizing dialog, everything else seems to. I always use png so haven't noticed before. Cheers, Al

Another option is considered here but uses Inscape too: https://superuser.com/questions/68679...

Earnest Al gravatar imageEarnest Al ( 2020-07-03 10:31:43 +0200 )edit

Print to file gives a .PRN format, no other choices. Exporting PNG I get a dialog asking for compression, not resolution. If I choose 1, the minimal and default value, I should the highest resolution, shouldn't I? Transforming the PNG obtained in this way to TIFF I get only 96 dpi. And I'm stuck. The publisher wants 300 dpi and I have no idea how to get that value!

pincopallino gravatar imagepincopallino ( 2020-07-03 11:30:42 +0200 )edit

That's odd. When you File | Export and choose file type of PNG, you should get in the dialog: Size and resolution, Compression, Mode, Save transparency. The dialog should look similar to the picture on the StackOverflow site I linked to.

I'm using LO6.4.4.2 on Win 10 Pro 2004

Earnest Al gravatar imageEarnest Al ( 2020-07-03 12:00:13 +0200 )edit

Are you the author of your pictures? If so, save them as SVG. SVG is a vector format which automatically adapts to the display device resolution (screen, printer, etc.). It can also be converted easily in any bitmap (raster-graphics) format and any resolution, e.g. with GIMP.

ajlittoz gravatar imageajlittoz ( 2020-07-03 12:02:22 +0200 )edit

File Export yes, but Print to file not . And when I export PNG with minimal compression and then convert it to TIFF I get 96 dpi only. SVG is not an option. The publisher wants TIFF and only TIFF. I haven't tried SVG but BMP gives again insufficient resolution when converted to TIFF. I'm totally ignorant about graphics, but why one cannot change the resolution when exporting to TIFF?

pincopallino gravatar imagepincopallino ( 2020-07-03 12:47:05 +0200 )edit

I don't understand why you can't see the size and resolution in the dialog after export as png. It is there in Linux mint, in Windows 10, and obviously in Mac as shown on the stack overflow website. What operating system and LO version are you using?

Anyway if it isn't there then you must export as svg and convert to TIFF in gimp or inkscape as ajilttoz suggested in previous comment

Earnest Al gravatar imageEarnest Al ( 2020-07-03 13:08:01 +0200 )edit

Describe your workflow. How do you create your pictures/Do you retrieve them from external sources? Do you separate picture preparation from integration into the document?

Managing picture originals outside LO (at least outside Writer) would give you freedom of processing. Before you insert them into Writer, you can tune their publishing properties in GIMP (printing format, resolution, scaling, colours, …). It is usually better to store illustrations in an "abstract" high quality vector format and later "downgrade" the pictures to publishing requirements instead of working from the start in the final output format.

Note that TIFF format is becoming quite old though it is one of the favourites of publishing industry.

ajlittoz gravatar imageajlittoz ( 2020-07-03 13:11:30 +0200 )edit

And if you increase the figures' size by 4.17 and then export to TIFF? 72 dpi × 4.17 ≈ 300 dpi.

LeroyG gravatar imageLeroyG ( 2020-07-03 13:50:29 +0200 )edit

Win 10 version 2004, LO version 6.4.5 Figure drawn with Draw, exported to PNG 236x236 pixels, bit depth 32 (whatever that means). Exported to TIFF, without compression, with PhotoFilter, I get 96 dpi. I tried to double the size, the final TIFF is still 96 dpi

pincopallino gravatar imagepincopallino ( 2020-07-03 14:22:03 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2020-07-03 17:34:30 +0200

ajlittoz gravatar image

Since the images are sent separately from the text, create your images with a convenient vector application (Draw is a good one). Save them in .odg format (if under Draw) for future edits.

When you're ready to send, export the files as .svg. This is also a vector format which will allow lossless image manipulations, while TIFF and PNG are raster formats (= bitmaps), which will cause distortion or pixellation when the images are adjusted.

If you are using Gimp for the conversion, first scale your image with Image>Scale & Size. This is where you can set image resolution.

As an example, the image below was initially a .png. When opened in Gimp, it reported at 96 dpi (which is supposed to be the "standard" screen resolution nowadays). I changed the resolution to 300 dpi and simultaneously applied a 300% increase factor to the size to compensate for denser dots. 300% is not exactly 300/96 but this was a quick'n'dirty test. If you start from a .svg, there will be a better overall quality.

upscaled tiff

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

edit flag offensive delete link more

Comments

Thanks, that did the job. Much indebted!

pincopallino gravatar imagepincopallino ( 2020-07-04 15:41:46 +0200 )edit

Be kind enough to accept the answer by clicking (only once, even if you don't see immediate change) on the gray tick mark at top left of answer.

ajlittoz gravatar imageajlittoz ( 2020-07-04 15:45:56 +0200 )edit
3

answered 2020-07-04 02:38:03 +0200

Earnest Al gravatar image

If you can see the compression for png then you should be able to see the size.

In the menu File | Export... , an Export dialog opens, in File Name: [you choose], Save As Type: PNG , (don't tick the box that says Selection as it crops overly zealously) click the Save button. A new window will open PNG Options.

  1. Remember the width
  2. Change the Resolution to 300 dpi (or as desired)
  3. Go back to Width and change it back to the value you remembered in step 1 (This is important as it will have reduced as you increased resolution)
  4. Probably ignore compression
  5. Tick transparency or not as desired and OK out
  6. Open the PNG file in Gimp or other image editor crop to size and Save as TIFF See picture for the PNG Option dialog: image description Cheers, Al
edit flag offensive delete link more

Comments

It worked! The resolution I finally got in the TIFF is more than twice of what I have chosen in the PNG, but it does not matter. The final file is huge but that is not a problem either. Thanks for your help!

pincopallino gravatar imagepincopallino ( 2020-07-04 15:43:07 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-07-03 08:27:17 +0200

Seen: 89 times

Last updated: Jul 04