Ask Your Question
0

Cant change username when opening remote file though FTP

asked 2020-07-24 11:02:42 +0100

aphditya gravatar image

Hi, I am using ubuntu 20. When I double click a word document directly from nautilus at a certain FTP server, this happend. image description

any idea how to change the username?

edit retag flag offensive close merge delete

Comments

When I double click a word document directly from nautilus

Then nautilus asks for the password and your question doesn't seem to be related to LibreOffice at all.

Opaque gravatar imageOpaque ( 2020-07-24 12:33:29 +0100 )edit

but nautilus dont asks for pdf/txt/ other ext. thats why I thought its libre's configuratio

aphditya gravatar imageaphditya ( 2020-07-24 12:42:08 +0100 )edit
1

The issue is: If you open a word document from a directory (regardless of being a local disk or a remote filesystem) you need immediate write access, since LibreOffice wants to create a lock file .~lock.<filename>#. And if you want to have write access to the FTP server you need to be authenticated. But you originally have been logged in as anonymous. This does not happen on any file just being opened for read access only (the extension in fact doesn't matter - try to open a PDF and perform a Save Copy) . In fact: Start to connect to your FTP Server from the very beginning (i.e. before you browse and double click any file) using:

  • Open Nautilus
  • Click + Other Locations in the left pane (a Connect to Server will field appear at the bottom of Nautilus windows
  • Enter: ftp://<your-username-on-ftp-server>@10.10.27.121
  • Provide your password ...
(more)
Opaque gravatar imageOpaque ( 2020-07-24 12:53:30 +0100 )edit

That solve the problem. many thanks :D

aphditya gravatar imageaphditya ( 2020-07-28 03:10:05 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-07-28 17:08:33 +0100

Opaque gravatar image

updated 2020-07-28 17:09:17 +0100

For the records (according to @aphditya's last comment)

Start to connect to your FTP Server from the very beginning (i.e. before you browse and double click any file) using:

  • Open Nautilus
  • Click + Other Locations in the left pane (a Connect to Server will field appear at the bottom of Nautilus windows
  • Enter: ftp://<your-username-on-ftp-server>@10.10.27.121
  • Provide your password on the ftp server

See also my comment, regarding why other files (applications) don't force to provide your user credentials (LibreOffice requires immediate write access to the storage while just viewing files works with read-only access, which is provided using anonymous login by default.

Hope that helps.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-07-24 11:02:42 +0100

Seen: 49 times

Last updated: Jul 28