Ask Your Question
0

How to increase LO Base timeout on MariaDB? [closed]

asked 2013-11-17 02:49:29 +0200

JAM gravatar image

I am very appreciative of the good advice I've gotten here in the past.

I am currently connecting to MariaDB with the maximum timeout value set in Tools/Options/LibreOffice Base/Connections. org.openoffice.comp.drivers.MySQL.Driver is set to the max allowable value which is only 600 seconds = 10 minutes. This is and always will be a single-user system so there is not question of 'hogging' the connection.

I'd like to set the timeout to be much larger so that I can go to lunch without having to shut down my DB.

Alternatively, is there an easy way to reconnect after the connection has timed out without restarting the DB?

Thanks for any suggestions.

Jill

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-14 16:09:00.303971

1 Answer

Sort by » oldest newest most voted
1

answered 2013-11-18 23:05:41 +0200

JAM gravatar image

updated 2013-11-18 23:07:27 +0200

I have found a note to myself from last spring when apparently I used the correct search parameters to get this answer.

The answer: In a Terminal window, sudo gedit

Open: /etc/mysql/my.cnf

change: wait_timeout=xxx to wait_timeout=28000

I hope this helps someone else who want to increase the timeout of MariaDB (or MySQL).

--Jill

P.S. It would still be really nice if there were a way to reconnect easily without closing LO Base and reopening it. Is anyone working on this?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-11-17 02:49:29 +0200

Seen: 1,094 times

Last updated: Nov 18 '13