Ask Your Question
1

writer autocorrect while typing not working

asked 2020-09-23 22:17:41 +0200

Duane gravatar image

Version 7.0.0.3 Windows 10 all updates. Autocorrect while typing is ON. I searched but couldn't find any current info. I have autocorrect set to change im to I'm, dont to don't, etc. But they don't change while typing. They used to, long time user. Is there a setting somewhere else now? thank you in advance

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2020-09-25 13:32:54 +0200

Earnest Al gravatar image

updated 2020-09-25 13:39:35 +0200

Make sure that you have a document language set, if no language is set then AutoCorrect and spell check will not run. If, for example, your document language should be English (UK) then click Tools > Language > For all text > English (UK). Make this for all documents by clicking Tools > Options > Languages > Default languages for all documents and set to English (UK). Note that you should have a tick and ABC next to the language otherwise spell check won't work (download appropriate language dictionary extension).

Your document language and the language in Autocorrect must be the same for the entries to be inserted. If, for example, your document language is English (UK) then in the menu click Tools > Autocorrect > AutoCorrect Options, select the Replace tab. In the top field, Replacements and exceptions for language, make sure that English (UK) is selected then ensure that your expected replacement is in the list. Cheers, Al

edit flag offensive delete link more

Comments

Hi, I went through what you outlined. Everything is set to English USA. Here: Tools > Language > For all text > English (USA). It won't stay check marked. In other words. I click it and come back and look and it's not checked. For Selection remains checked but the other two do not. When I type this in :<=: it should change it to the less than or equal to symbol. It doesn't. Autocorrect will not correct anything within its list.

Duane gravatar imageDuane ( 2020-09-25 20:49:06 +0200 )edit

Having set your language for new documents to English (USA) in Tools > Options > Languages > Default languages for all documents, when you open a new document does the bar at the bottom centre say English (USA)?

If it does, then in the new document does the Autocorrect change :<=: to ≤ ?

If it does then it might be your document language not set properly. Click in your text, press Ctrl+A (select all), then click Tools > Language > For all text > English (USA). Now try the the Autocorrect change :<=: to ≤

Earnest Al gravatar imageEarnest Al ( 2020-09-26 00:23:46 +0200 )edit

Thank you for continuing to help. A new document does say English (USA) at the bottom. :<=: does not change. Doing CTRL A and then click Tools > Language > For all text > English (USA) does not put a checkmark as it does for For Selection. Should checkmarks be on all three? Nothing changes from the autocorrect list.

Duane gravatar imageDuane ( 2020-09-26 02:56:59 +0200 )edit
1

Paragraph and All text don't have checkmarks against them. Existing Replace Withs, e.g. :<=: for Autocorrect won't happen by themselves, they need to be triggered by a space or paragraph afterwards, but you can click Tools > Autocorrect > Apply to trigger the change.

If that doesn't work you could see if Autocorrect will work when you are in Safe Mode, click Help > Restart in Safe Mode . Try Autocorrect in a new document while in Safe Mode. If that is the only way to get it to work then you will have to consider whether you want to reset your profile. Resetting your profile will, remove all your customisations, including Autocorrect entries and words added to your dictionaries. You can archive your old settings and then gradually re-introduce the important ones but it can be time-consuming. When you restart in Safe Mode you get offered ...(more)

Earnest Al gravatar imageEarnest Al ( 2020-09-26 05:35:21 +0200 )edit

Hi While I never mentioned it I was hitting the space bar afterward. I will do the safe mode and post the results here. The good news it does work in safe mode. And the even gooder news is it's fixed. Sorry about my grammar. Everybody knows its more gooder. hahaha. Thank you so much for helping with this. I would have never figured this out.

Duane gravatar imageDuane ( 2020-09-28 01:28:25 +0200 )edit

Your user profile is corrupted. You will probably want to reset your profile, here is more information on UserProfile. So archive profile first and then reset

Earnest Al gravatar imageEarnest Al ( 2020-09-28 04:03:59 +0200 )edit
0

answered 2020-09-23 22:35:27 +0200

lazarus477 gravatar image

Please try these instructions: Checking Spelling and Grammar.

edit flag offensive delete link more

Comments

I don't understand. How does checking spelling fix the autocorrect not working?

Duane gravatar imageDuane ( 2020-09-23 23:08:38 +0200 )edit

Problems with spellcheck and problems with autocorrect are often caused by the same: by incorrect text / input language.

gabix gravatar imagegabix ( 2020-09-25 14:51:38 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-09-23 22:17:41 +0200

Seen: 57 times

Last updated: Sep 25