We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

[SOLVED] set/unset the "double-lined" format in LO 7.0.0 Writer's footnotes [closed]

asked 2020-10-09 16:13:51 +0200

CBhihe gravatar image

updated 2021-05-29 17:59:00 +0200

Alex Kemp gravatar image

For some reason on my LO 7.0.0, Writer suddenly decided that every footnote's format would now be double-lined, not doubled (as in repeated) but "double-lined", i.e. again, not repeated but each footnote font is reduced in such a way that two line worth of content are displayed in one line worth of space. The font is reduced proportionally in the horizontal and vertical directions so I can see two lines of smaller characters where previously there was space for only one line. Needless to say it is wholly unreadable.

I have tried modifying the Footnote style from the style window (F11) and also from the Format > Page Style. Nothing doing.

Has anyone seen this before and knows how to get rid of it ? - Cheers.

Edit: I add both a snapshot and a sample odt document with the "double-lined" footnotes.

C:\fakepath\doubled-line-format-for-Writer-footnotes.png

C:\fakepath\sample-bizarre-footnote.odt

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2021-05-29 17:59:48.875101

Comments

Some way or other you have changed the footnote font size. Have you tried to select the full note and Ctrl+M?

If you can't sort things out, the simplest is to attach a sample file to your question. Caution! attaching a file can only be done on a question (not possible on a comment). Consequently, edit your question (press on the link under it) and use the paperclip tool.

ajlittoz gravatar imageajlittoz ( 2020-10-09 17:10:16 +0200 )edit

@ajlittoz: thanks. I added the pix and, no, CTRL-M does not change at all the strange doubled-line formatting. I did try changing font size and all as a reaction to that bizarre format, but to no avail. It just appeared spontaneously and I know how that sounds... But I really did not do anything that could directly induce that behavior.

CBhihe gravatar imageCBhihe ( 2020-10-09 17:55:28 +0200 )edit

A screenshot is of little help. Attach an .odt file to your question (a 1-page sample is enough).

All I can tell is you don't use paragraph styles as they should because you space your paragraphs with empty ones, meaning your text is probably Default Style instead of Text Body. But this is secondary compared to the problem.

ajlittoz gravatar imageajlittoz ( 2020-10-09 18:02:20 +0200 )edit

In the style for the footnote in the position tab, do you have Normal selected or is sub script or super script selected? It should be Normal

Earnest Al gravatar imageEarnest Al ( 2020-10-10 12:30:06 +0200 )edit

By reading others post, OP seems to work with Linux, so I doubt that it saved the document as doc(x); but not sure.

@Earnest Al, Can't be sub/superscript; see the footnote number and paragraph symbol (¶).

LeroyG gravatar imageLeroyG ( 2020-10-12 01:07:55 +0200 )edit

@LeroyG: I doubt OP is under Linux. Times New Roman is a Windows font.

ajlittoz gravatar imageajlittoz ( 2020-10-12 07:45:12 +0200 )edit

Hi. I do work with lunux. Exclusively. Installing any font including Times New Roman is possible on any linux system. The issue is indeendent of weather TNR is installed though. Thanks

CBhihe gravatar imageCBhihe ( 2020-10-12 11:03:42 +0200 )edit

Please attach a 1-page sample file to your question. The page corresponding to the screenshot is a good example.

ajlittoz gravatar imageajlittoz ( 2020-10-12 11:07:26 +0200 )edit

Hi all sorry for the typos in my previous comment ("lunux -> linux" and "weather -> whether"). I was out in the backcountry when I posted. I added a sample odt file with the bizarre format for the footnote. Thank you for your collective help.

CBhihe gravatar imageCBhihe ( 2020-10-12 15:47:01 +0200 )edit

Footnote paragraph style says Double-lined.

LeroyG gravatar imageLeroyG ( 2020-10-12 16:04:23 +0200 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2020-10-12 17:53:33 +0200

ajlittoz gravatar image

updated 2020-10-12 21:01:41 +0200

My answer got lost into limbo. So here it is again.

I was not aware of the existence of the "double-lined" attribute and I misunderstood the question.

I had a look at the XML and could not see anywhere a setting for this attribute either in the paragraph style or the character styles.

Built-in help mention it, mainly for Asian scripts, but it can be set too for Western scripts. There seems to be no UI to set it and even less to reset it. I made a try in advanced configuration of Tools>Options with "double-line" key but found nothing ("double" gets too many hits because it is a value type).

The attribute is very sticky. Event Standard in all tabs of Footnote does not reset it.

The only workaround is to completely recreate a FootnoteErsatz to replace Footnote. Don't attempt to right-click on Footnote and New because it will "import" (more accurately inherit) all attributes of Footnote, including the double-lined one (which I can't override). To get a fresh style, right-click on Default Style and New.

However, this is not acceptable for production.

I feel this is a preliminary implementation of some undocumented feature and no UI is ready yet. There may be a key combination for developers you inadvertently stroke and enabled the attribute. I found nothing related to "double-line" in Tools>Customize, Keyboard tab. It is likely to be a Shift added to a very common keyboard shortcut (I base my guess on the fact that the note is direct formatted instead of using character styles. -- Rule out Ctrl+Shift+B; Ctrl+Shift+I has no effect).

My version is 6.4.6.2.

EDIT after additional information provided by @CBhihe

The Double-lined attribute is only accessible when Asian features have been enabled in Tools>Options, Language Settings>Languages. If Asian is not checked in Default Languages for Documents, check this box first to allow display of additional Asian options in the dialogs. If you don't, the "double-lined" attribute while still active can't be changed.

To remove or set this attribute, right-click on a style name (paragraph or character style) and Modify (as usual).

Thanks to the options setting above, new tabs are shown in the style configuration dialogs: Asian Layout and Asian Typography.

Go to Asian Layout and uncheck the Write in double lines box to disable the feature or check it to enable it and configure the enclosing characters.

Eventually, remove the Asian language option if you checked it only for the purpose of accessing the Asian attributes.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

@ajlittoz, I also had trouble posting this morning in this question; and a few comments disappeared (yours and mine).

LeroyG gravatar imageLeroyG ( 2020-10-12 18:19:15 +0200 )edit

Yes, indeed, @ajlittoz, thank you. You pointed me to the right place. You'll find the exact solution below, for LO 7.0.0 on Linux. (If you edit your answer to somehow include it, I will be glad to accept it as the official answer.)
================
Placing cursor on Footnote and pressing F11, right click on : "Default Paragraph style" > "Footnote", select "Asian Layout" tab, and uncheck box "Write in double lines".
================
Don't ask me why this was ever selected in the first place. No clue. FYI, I do implement iBus for Japanese and Chinese type sets and keyboard transliteration. So comes to mind that "iBus" just might be involved in this snafu. However if this turns out to be a bug, it might just as well be iBus' doing. No way to know that without diving into the code.

CBhihe gravatar imageCBhihe ( 2020-10-12 20:27:39 +0200 )edit
1

@CBhihe thanks for making me discover these Asian features.

Incidentally, use character styles to have a more robust (and comfortable) formatting. All your intra-paragraph is wiped out by Ctrl+M while it is kept if it is applied with character styles. Additionally, character styles allow you to control formatting from a single location, just like you do for paragraphs with paragraph styles.

ajlittoz gravatar imageajlittoz ( 2020-10-12 21:05:25 +0200 )edit

Thank you again. And yes, your answer is 100% correct. I had enabled "Asian" in Default Languages for Writers Documents (per your indication: Tools>Options, Language Settings>Languages.). Apparently in that case "double-lined" footnotes become the default format setting.

CBhihe gravatar imageCBhihe ( 2020-10-12 21:35:51 +0200 )edit
0

answered 2020-10-12 17:07:17 +0200

LeroyG gravatar image

updated 2020-10-12 17:10:47 +0200

While the cursor in the footnote, press F11 and in paragraph Styles choose Footer.

With LibreOffice 6.3.6.2 (x86); OS: Windows 6.1.

See that, since LibreOffice 7 is working with ODF 1.3, menu Format - Paragraph… may have a double-line option somewhere.


Add Answer is reserved for solutions.

Press edit below your question if you want to add more information; also can comment an answer.

Check the mark (Correct answer mark) to the left of the answer that solves your question.

edit flag offensive delete link more

Comments

@LeroyG: thanks for your help. on LO 7.0.0 (x86) on Linux, Format > Paragraph has no "Asian Layout" tab and no "Write in double-line" check box. This formatting option is completely absent from GUI. Per my comment in response to @ajlittoz' answer, "Asian Layout and said checkbox do appear pressing F11, and right clicking on : "Default Paragraph style" > "Footnote" ...

CBhihe gravatar imageCBhihe ( 2020-10-12 20:38:09 +0200 )edit

I'm glad it's solved.

LeroyG gravatar imageLeroyG ( 2020-10-12 20:44:59 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2020-10-09 16:13:51 +0200

Seen: 115 times

Last updated: Nov 19 '20