How can I "undo" a recovery?

asked 2020-10-12 01:05:33 +0100

arrow360 gravatar image

I opened a spreadsheet (that I use often) and received the message about "recovery". Thinking something happened at the last shutdown, I clicked "OK". After the recovery process, the spreadsheet opened and now the data is from a year ago. How can I "undo" a recovery? Thanks!

edit retag flag offensive close merge delete

Comments

I would suggest doing a Save As [another name] for the recovered document and re-opening the original again

Earnest Al gravatar imageEarnest Al ( 2020-10-12 06:35:03 +0100 )edit

Thanks for the reply! The only thing I could think of was to close the document and re-open. And that was the same version with year old data.

arrow360 gravatar imagearrow360 ( 2020-10-12 13:29:20 +0100 )edit

With long term documents, I often Save a copy with the same name but with that day's date appended so that in the event of problems I can revert. I normally do this just before I make big changes.

Earnest Al gravatar imageEarnest Al ( 2020-10-12 23:05:24 +0100 )edit

Since the software requested the recovery, I assumed something happened during the most recent closing. So, not sure why it went back an entire year. Unless someone knows a fix, I've lost a year's worth of data entry.

arrow360 gravatar imagearrow360 ( 2020-10-12 23:39:25 +0100 )edit

Probably it looked at the last backup. Go to Tools > Options > LibreOffice > Paths and see where backups are stored. You might be able to copy the most recent backup to a new folder in your working folder and rename the extension. Of course if it it's a year old then it is probably the "recovered" one.

You can turn on backups if they're turned off in Tools > Options somewhere, I can't check right now as my wife's computer just had a Windows update so isn't working properly and she has taken mine.

Earnest Al gravatar imageEarnest Al ( 2020-10-13 01:09:30 +0100 )edit

"Save AutoRecovery" was turned "ON". Set for every 10-minutes. But I could not find the directory as to where those files are stored. Always create a backup copy is turned "OFF". These are the default settings, as I have not changed them.

arrow360 gravatar imagearrow360 ( 2020-10-13 02:13:31 +0100 )edit

Also forgot to mention that I checked the "Path" and the box was empty. So, there has been no location set for backups.

arrow360 gravatar imagearrow360 ( 2020-10-13 02:56:08 +0100 )edit

You could look in Temporary Files

Earnest Al gravatar imageEarnest Al ( 2020-10-14 02:27:48 +0100 )edit

I went to Paths > Temporary Files, but all of those folders were empty. I turned on "Hidden" in the View, and still nothing.

arrow360 gravatar imagearrow360 ( 2020-10-15 03:47:42 +0100 )edit

I'm sorry. It sounds as if the data is gone unless you have a backup or you have emailed it anywhere.

Earnest Al gravatar imageEarnest Al ( 2020-10-15 08:13:28 +0100 )edit