How can I "undo" a recovery?

I opened a spreadsheet (that I use often) and received the message about “recovery”.
Thinking something happened at the last shutdown, I clicked “OK”.
After the recovery process, the spreadsheet opened and now the data is from a year ago.
How can I “undo” a recovery? Thanks!

I would suggest doing a Save As [another name] for the recovered document and re-opening the original again

Thanks for the reply! The only thing I could think of was to close the document and re-open. And that was the same version with year old data.

With long term documents, I often Save a copy with the same name but with that day’s date appended so that in the event of problems I can revert. I normally do this just before I make big changes.

Since the software requested the recovery, I assumed something happened during the most recent closing. So, not sure why it went back an entire year. Unless someone knows a fix, I’ve lost a year’s worth of data entry.

Probably it looked at the last backup. Go to Tools > Options > LibreOffice > Paths and see where backups are stored. You might be able to copy the most recent backup to a new folder in your working folder and rename the extension. Of course if it it’s a year old then it is probably the “recovered” one.

You can turn on backups if they’re turned off in Tools > Options somewhere, I can’t check right now as my wife’s computer just had a Windows update so isn’t working properly and she has taken mine.

“Save AutoRecovery” was turned “ON”. Set for every 10-minutes. But I could not find the directory as to where those files are stored.
Always create a backup copy is turned “OFF”.
These are the default settings, as I have not changed them.

Also forgot to mention that I checked the “Path” and the box was empty. So, there has been no location set for backups.

You could look in Temporary Files

I went to Paths > Temporary Files, but all of those folders were empty. I turned on “Hidden” in the View, and still nothing.

I’m sorry. It sounds as if the data is gone unless you have a backup or you have emailed it anywhere.

That’s what I expected. Just weird for the software to do this. Thank you for the attempts.