Ask Your Question
1

Font bug on LO 4.1 when opening documents created with LO 4.0 [closed]

asked 2013-12-13 10:07:01 +0200

Tom V. gravatar image

updated 2015-08-30 00:20:49 +0200

Alex Kemp gravatar image

Hello,

LO 4.1 on mac treats fonts differently than LO 4.0. Especially when dealing with fonts that have special "weights". This leads to bad results when opening in LO 4.1 documents created with LO 4.0 that uses such fonts.

For example the Deja Vu font also exists as Deja Vu Light. In LO 4.0, it is displayed as a different font than Deja Vu. In LO 4.1, it is considered as part of the Deja Vu package. The images below illustrate this bug.

LOv4.0.x:

LOv4.0.x font selection

LOv4.1.x:

LOv4.1.x font selection

Tooltip error:

LOv4.1.x tooltip

Should I file a bug report?

A similar question was asked before:

http://ask.libreoffice.org/en/questio...

Best, Tom

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 22:20:07.930362

2 Answers

Sort by » oldest newest most voted
1

answered 2013-12-13 23:29:27 +0200

oweng gravatar image

updated 2014-09-21 09:14:50 +0200

Please do not open a new bug as it is a known problem with many existing duplicate bug reports. This may be several problems rolled into one, as the font handling in LO v4.1.x for MacOS evidently has a problem with weights and there is a problem with LO-provided fonts not displaying. The two different types of problem appear to be:

  • fdo#67749, Fonts are missing from font name selector.
  • fdo#69254, Custom font handling[1]

Also related is enhancement fdo#66792 which will provide a method of selecting font sub-styles (italic, oblique, bold, semibold, etc.).

[1] The originally linked bug (fdo#67744) has since been closed in favour of this report. I included fdo#67744 because the screenshots provided show this effect, so thought it may be related.

edit flag offensive delete link more
0

answered 2014-09-17 19:10:38 +0200

dwight gravatar image

I'm on libreoffice 4.3.1.2., Mac OSX 10.9.4. Has there been any progress on this issue since 4.1? Is there a way for example to access the true italic typeface and not simply a forced oblique?

edit flag offensive delete link more

Comments

@dwight, it would appear that at present there are numerous problems with the MacOS build of LO (partly b/c Apple loves to change things all the time without concern for backward compatibility). In this instance (font handling) it may be some time before a resolution is forthcoming. Can you edit your answer to mention which font is offering a "forced oblique"?

oweng gravatar imageoweng ( 2014-09-21 09:17:50 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-12-13 10:07:01 +0200

Seen: 2,377 times

Last updated: Sep 21 '14