Ask Your Question
0

In a writer document i want to be able to click on hyperlinks and have that take me to the connected bookmarks.

asked 2020-10-15 03:17:24 +0100

richa gravatar image

updated 2020-10-16 13:43:42 +0100

Nothing happens when i click on those hyperlinks except a little note comes up telling me to click on the hyperlink to get to the bookmark! I have LibreOffice version 6.3.4.2ookmar

C:\fakepath\hyperlink question.odt

Here is the new attachment:

C:\fakepath\hyperlinkbookmarktest.odt

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2020-10-15 08:04:04 +0100

ajlittoz gravatar image

updated 2020-10-16 14:56:42 +0100

Transfer to destination is usually done with Ctrl+click. Have you tried this?

EDIT 2020-10-15

Your hyperlink requests transfer to boomark bookmark 1 which does not exist.

Set the cursor where you want the bookmark to be, Insert>Bookmark and enter its name. Now, when you Ctrl+click on the hyperlink, you jump to the bookmark.

I don't know if the sample file is representative of your skill in LO, but I recommend you use styles and not direct formatting to format your real document.

EDIT 2020-10-16

CAUTION! Bookmark names are case-sensitive! So, check the names are exactly the same in casing.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

I did try that, and it also does not work. I want eventually to share this document with others and have them also be able to click on the links to get to the bookmarks.

richa gravatar imagericha ( 2020-10-15 13:25:35 +0100 )edit

Edit your question in order to attach a sample file (2 pages max. with an hyperlink and a destination bookmark, preferentially not on the same page).

ajlittoz gravatar imageajlittoz ( 2020-10-15 13:38:28 +0100 )edit

I do not see how to attach a file, so have copied the appropriate. lines below. The hyperlink is "Appendix 1" in the first line. The bookmark is at the beginning of the second line:

i have reproduced the essence of that flyer in Appendix 1.

Appendix 1: Van Andel Museum Leaflet

richa gravatar imagericha ( 2020-10-15 14:22:47 +0100 )edit

Copying a description of your document is not the same as the document itself.

To attach, click on the edit link below your question. Scroll to bottom. Press Enter at least twice. Click on the "paperclip" tool in the edit toolbar. A dialog pops up. Press Browse to select a file. OK.

ajlittoz gravatar imageajlittoz ( 2020-10-15 16:31:18 +0100 )edit

File is uploaded per your instructions.

richa gravatar imagericha ( 2020-10-15 22:02:46 +0100 )edit

Somehow the bookmark did not copying the short document i sent, but it is there in my original document. In any case, i tried control-click on the modified version of the short document that does have a bookmark and it still did not go to the bookmark. I am pretty ignorant when it comes to working in LibreOffice writer generally, but trying to work with styles intimidates me - that is part of my ignorance i guess.

richa gravatar imagericha ( 2020-10-16 03:55:11 +0100 )edit

If you are sure you added the bookmark in the sample document (use of Insert>Bookmark), edit again your question to attach the new one (keep the older one so that I can see the difference).

ajlittoz gravatar imageajlittoz ( 2020-10-16 08:18:32 +0100 )edit

Nothing serious: you just created a discrepancy between your bookmark Bookmark 1 with an uppercase "B" and the target bookmark 1 with a lowercase "b" in the hyperlink.

Bookmarks are case-sensitive. Fix spelling and it works.

ajlittoz gravatar imageajlittoz ( 2020-10-16 14:54:20 +0100 )edit

Problem finally solved - thank you! One thing for you to know, however: control-click does not doi t; that brings up a menu. It requires command-click.

richa gravatar imagericha ( 2020-10-16 22:14:23 +0100 )edit

Are you under MacOS? You didn't mention it. Under MacOS, whenever documentation says Ctrl+something, replace it with Command+something. This illustrates the importance of mentioning the OS, even for seemingly insignificant matters.

ajlittoz gravatar imageajlittoz ( 2020-10-17 07:55:14 +0100 )edit
0

answered 2020-10-16 02:03:49 +0100

updated 2020-10-16 02:04:48 +0100

Hello @richa

the Dokument you uploaded does not seem to have the bookmark set. At least it does not get displayed for me via View-> Navigator (F5)

Here i added it, try via CTRL+Click and see if it works for you.

C:\fakepath\16027920396372988_modified.odt

Hope that helps.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-10-15 03:17:24 +0100

Seen: 83 times

Last updated: Oct 16