Ask Your Question
1

Writer document with greyed out Table numbers in navigator pane

asked 2020-10-17 20:25:53 +0100

Christian M gravatar image

updated 2020-10-18 14:28:53 +0100

Hi,

I have created a long time ago a LO Writer document that I use for writing all of my documents. I updated and changed it over the past few years and it is all fine. However I noticed that when I open up a blank document with that document the Tables 1, 2, and 4 are already in use in the navigator pane. See attached image:

image description

This means that when I then insert a table into the text file the first table will be automatically Table 3 and the next one then Table 5 and so on. Here's a screen shot of a current document I am working on:

image description

When I create a default blank Writer document then this issue does not exist:

image description

Currently I am using LO v6.4.4.1 (x64) on a Windows 10 Pro Laptop.

Is there a way to fix this numbering issue?

I don't want to set up the entire document manually from scratch again.

Thanks!

--Christian M

C:\fakepath\my_default.odt

edit retag flag offensive close merge delete

Comments

The first one: Update to LibreOffice after 6.4.6 https://www.libreoffice.org/download/...

If that doesn't help try the safe mode: https://www.libreoffice.org/download/... When the error is gone you have to renew your user profile: https://wiki.documentfoundation.org/U...

Alternatively you can explain: In which file format do you save? Was the file previously a DOC or DOCX file?

Someone can also look it up: To do this, reduce and anonymize your file (the error must be present) and upload the file here.

To upload, edit your initial question and use the paper clip icon. Thank you.

ebot gravatar imageebot ( 2020-10-18 09:16:01 +0100 )edit

Thank you, ebot.

Tried with LO v6.4.6.2 and also started it in Safe mode. Unfortunately the issue is still there.

I have now sanitised and attached my file.

FYI - I created it a couple of years ago with LO v4.x, I can' remember the version, and updated it over the years with newer versions of LO. The latest update was made with LO v6.4.4.1.

Thank you very much for your help !

--Christian M

Christian M gravatar imageChristian M ( 2020-10-18 14:31:15 +0100 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2020-10-18 15:26:06 +0100

ajlittoz gravatar image

updated 2020-10-18 15:50:51 +0100

Your document contains custom page styles Index Right, Index Left and Index Standard with fancy headers. These headers are made with 2-column tables.

As long as your document does not contain such a page, the table names are grayed out and you can't jump to them double-clicking.

If you feel like having your "content" tables sequentially numbered, without the header tables in the way, rename the header tables:

  1. create a page with the desired page style
  2. the table name is now enabled
  3. right-click on it and Table>Rename
  4. give it a meaningful name such as "Index Right Title Block"
  5. delete the page

Side remark: table names such as Table99 are not very useful because they are numbered and listed in order of creation, not in document order. I prefer to systematically rename them with a descriptive name so that I can identify quickly the one I want to navigate to.

Organisation remark: save your document as a template to eliminate the risk of overwriting it in case you forget to Save As instead of Save. You can even make it your default template so that all your future documents will be automatically formatted based on this template.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

Many thanks, ajlittoz.

In the past few weeks I had no need to use the "Index Right/Left/Standard" Page definitions anymore. By deleting these definitions the issue has been resolved.

I also now remember what I did that caused this issue in the first place:

When I defined these Index pages I added a table to the header and put some text into it that should appear automatically when I insert an Index page.

But now I have no need for these pages anymore.

I will also take note of your tip with renaming tables to something different when I need.

Again, many thanks for your help!

--Christian M

Christian M gravatar imageChristian M ( 2020-10-18 15:41:20 +0100 )edit

You're welcome

ajlittoz gravatar imageajlittoz ( 2020-10-18 15:51:06 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-10-17 20:25:53 +0100

Seen: 26 times

Last updated: Oct 18