Ask Your Question
0

Errors Cause Missing Data

asked 2020-10-20 19:44:48 +0100

vw-office gravatar image

updated 2020-10-21 04:39:46 +0100

I copy data from a LibreOffice Spreadsheet and paste it to LibreOffice Base. After selecting the column data type, I get a Java exception error. Data is missing in three columns of the created table. Two of them have the date data type and the other one has the varchar data type. Is it a bug? Also, when I try to repeat the process, I can't get the create table part work. It seems to be another bug.

For a request, I attach a screenshot of a part of the spreadsheet file to this post.

image description

edit retag flag offensive close merge delete

Comments

We need a little more information to try to help you. What kind of database setup/connection do you have - HSQLDB embedded, Firebird embedded, etc. What is your computer setup (computer type & operating system), what version of LibreOffice are you using? Please give a step by step list of your data importing procedure - including whether (or not) you you are creating the empty database table first before you are importing your data. Are the columns in your Cal sheet formatted property? Dates should be formatted as DATE type and YYYY-MM-DD. See the GUIDELINES for importing data from Calc into Base HERE.

frofa gravatar imagefrofa ( 2020-10-20 22:43:34 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-10-20 22:54:54 +0100

frofa gravatar image

updated 2020-10-21 05:06:23 +0100

See comments below and above (revised).

edit flag offensive delete link more

Comments

Thanks very much for your information. The date format is the cause. I, however, don't know how to change the existing data of the date format. I have changed the column date format to yyyy-mm-dd. The format only applies for the newly entered date, but not the existing date which is the default US date format. After having some online search, I haven't found a solution.

vw-office gravatar imagevw-office ( 2020-10-21 03:07:37 +0100 )edit

Formatting DATES can be tricky. Once you know the method, it's pretty straightforward. How many problem dates do you have? Would you provide a screenshot of the problem part of your Calc sheet and we might be able to give you some steps to follow. You'll need to upload your screenshot to your original question (comments can't display images).

frofa gravatar imagefrofa ( 2020-10-21 03:55:16 +0100 )edit

Not sure why a screenshot is needed. It is a normal CSV file. I add it anyway.

vw-office gravatar imagevw-office ( 2020-10-21 04:40:52 +0100 )edit

Sorry I meant to ask to select one of your US date entries before doing the screenshot

So try these steps:

  1. Click on a single problem (US format) date and see if there is a leading ' character (just before the date)
  2. You will need to remove these before using the FORMATING control to change the date to XXXX-MM-DD
  3. If there are a lot of 'problem' (US) formatted dates, there is a batch way to do it.
  4. Note: The entire column should be formatted as DATE XXXX-MM-DD
frofa gravatar imagefrofa ( 2020-10-21 05:05:40 +0100 )edit

Thanks for the info. I recognize that I have spent an unreasoned amount of time on the task. It could be done by just removing unwanted rows.

vw-office gravatar imagevw-office ( 2020-10-21 07:09:01 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-10-20 19:44:48 +0100

Seen: 72 times

Last updated: Oct 21 '20