EPS in PDF export going green

asked 2020-11-03 18:34:53 +0200

Richard Kirk gravatar image

updated 2020-11-04 12:03:11 +0200

I had fixed the EPS export problem. I have my version of pstoedit on the path. Then the EPS files went yellow-green. Then they disappeared and left a rectangle. Now they are back but yellow-green. I am using Writer 7.0 on my Catalina Mac. Recently gnuplot needed re-installing; it may be connected with that. But there is no good reason why gnuplot should have fallen over (bringing Octave down with it).

Here's an example of an EPS screen-grabbed from the exported PDF in preview. Looks the same in the Adobe viewer.

image description

Here is a test .odt

C:\fakepath\EPScolour.odt

I have a fix for Mac, if you install apps with 'brew' : run 'brew doctor'. This comes up with a list of warnings. In my case it suggested running `brew link ghostscript'. This was not straightforward as there were a lot of conflicting files from some non-brew install. But, once cleaned up, LibreOffice worked again.

edit retag flag offensive close merge delete

Comments

Hi, could you be a little more clear on what the actual problem is. From what i understand, the original Image "Kodak film transmission" was generated with gnuplot. And you inserted the image into LO Writer and on pdf export the background of the image changed? Is that the problem?

If it is, please attach the original image or a writer document with the image to your question, so we can have a look. Thanks.

igorlius gravatar imageigorlius ( 2020-11-03 19:11:49 +0200 )edit

That's right. The background is white on the original image (gnuplot terminal postscript ps color), and appears white in the document. The image looks good except for this weird colour. This has happened today, and it has the same effect on old versions of the .odt file, so it is not something in the .odt.

I recently had to update octave and gnuplot. I suspect this may have touched something that LO uses.

Does the environment flag LO_PREFER_GS_FOR_EPS do anything? I was going to give this a try.

Richard Kirk gravatar imageRichard Kirk ( 2020-11-03 19:19:54 +0200 )edit

If the behaviour changed after an update of gnuplot/octave, maybe something with their image output changed. (enabled transperance or something like that, maybe?) Or did you change the way how insert the images into LO Writer? Sorry, i am not familar with the LO_PREFER_GS_FOR_EPS Env. options.

igorlius gravatar imageigorlius ( 2020-11-03 19:39:44 +0200 )edit

While experimenting with LO_PREFER_GS_FOR_EPS, I found the problem disappears when running soffice from the command line.

I had two versions of pstoedit in /usr/local/bin and /opt/local/bin (3.75 and 3.70 respectively). The /usr/local/bin one cannot be updated by itself as brew knows octave is dependent on it. This may well have been updated when I tried to fix octave. However, replacing either version with the other one as no effect.

I have a workaround, so I am not panicking any longer. But there is something brittle here. Maybe someone will recognise the symptoms.

The original document has over 200 pages. I can make a smaller document.

Richard Kirk gravatar imageRichard Kirk ( 2020-11-03 21:25:58 +0200 )edit

I tried to reproduce your problem with my version of LO: 7.1.0.0.alphpa0+ and OS: linux/debian and the color of the background does not change to mustard on export to pdf at least with the sample document you provided. (my exported pdf: C:\fakepath\16044355457626367_remove_odt_extension.pdf.odt

I'll take a closer look at the image next and see if something catches my eye. Later.

igorlius gravatar imageigorlius ( 2020-11-04 10:20:02 +0200 )edit

Thanks for trying. I suspect this was caused by a pstoedit update on my system, but this is no help until I have a sensible way of reproducing it, or undoing it. Runing soffice from the command line helps. I shall see what I can do with that.

Richard Kirk gravatar imageRichard Kirk ( 2020-11-04 10:44:47 +0200 )edit