Ask Your Question
0

bug on CSV import? [closed]

asked 2012-02-21 07:52:53 +0200

El_Sivas gravatar image

HI,

I tried to import a CSV-file with calc.

COL1;COL2
1.2345.678;1234.567

On import data type "Standard" at both columns, COL1 is interpreted as String, whats correct. But COL2 is interpreted as integer. At the spreadsheet I get this:

COL1       COL2
1.2345.678 1234567

If COL2 where 1.234.567 I'd say its OK, to interpret this as integer, but not 1234.567 . Could this be a bug or is this a feature that I cannot see?

Greets

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-15 04:50:19.630367

Comments

For questions like this please always indentify the version/release of LibreOffice you are using.

bjoern-michaelsen gravatar imagebjoern-michaelsen ( 2012-02-21 11:32:00 +0200 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2012-02-21 15:14:08 +0200

cloph gravatar image

In the import dialog, just change from automatic detection to manually specifying the type. Click on the column, then either right-click or use the listbox to manually set the format to text.

And yes, how LO treats those "number-like" sequences depends on the number format for the selected language. You can change that as well, but in this case it doesn't make sense, as the columns really are text/identifiers, not numbers.

edit flag offensive delete link more

Comments

Yes, i know, if i choose "text", the Column is imported as text. I meant that the automatic recognition is maybe not good. However. I've also found this workaround, you mentioned.

El_Sivas gravatar imageEl_Sivas ( 2012-02-21 16:27:27 +0200 )edit
0

answered 2012-02-21 09:30:26 +0200

El_Sivas gravatar image

Uumh, yes, MS Excel does:

COL1         COL2
12.345.678   1.234.567

2003 and 2007. Actually my Strings were merged IDs from some objects with dot as separator. X-(

edit flag offensive delete link more
0

answered 2012-02-21 09:31:38 +0200

ehansen gravatar image

Both cols are imported as string for me....

Perhaps it has something to do with the language settings of LO? I use norwegian, so LO normally use "," as decimal point.

Does selcting/deselecting "Detect special numbers" at import do any difference?

edit flag offensive delete link more
0

answered 2012-02-21 08:16:27 +0200

nxd81483 gravatar image

updated 2012-02-21 09:49:48 +0200

I get:

COL1COL2
1.2345.6781234.567
edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-02-21 07:52:53 +0200

Seen: 1,064 times

Last updated: Feb 21 '12