Bug on CSV import?


I tried to import a CSV-file with calc.


On import data type “Standard” at both columns, COL1 is interpreted as String, whats correct. But COL2 is interpreted as integer. At the spreadsheet I get this:

COL1       COL2
1.2345.678 1234567

If COL2 where 1.234.567 I’d say its OK, to interpret this as integer, but not 1234.567 . Could this be a bug or is this a feature that I cannot see?


For questions like this please always indentify the version/release of LibreOffice you are using.

In the import dialog, just change from automatic detection to manually specifying the type. Click on the column, then either right-click or use the listbox to manually set the format to text.

And yes, how LO treats those “number-like” sequences depends on the number format for the selected language. You can change that as well, but in this case it doesn’t make sense, as the columns really are text/identifiers, not numbers.

Yes, i know, if i choose “text”, the Column is imported as text. I meant that the automatic recognition is maybe not good. However. I’ve also found this workaround, you mentioned.

I get:

1.2345.678 1234.567

Uumh, yes, MS Excel does:

COL1	     COL2
12.345.678   1.234.567

2003 and 2007. Actually my Strings were merged IDs from some objects with dot as separator. X-(

Both cols are imported as string for me…

Perhaps it has something to do with the language settings of LO? I use norwegian, so LO normally use “,” as decimal point.

Does selcting/deselecting “Detect special numbers” at import do any difference?