Ask Your Question
0

Why does LibreOffice replace Alegreya Sans' curly quote with its regular quote? [closed]

asked 2013-12-29 03:56:48 +0100

I am writing a document in the font Alegreya Sans. When I enter an apostrophe, it at first shows up as a curly apostrophe (U+2019 RIGHT SINGLE QUOTATION MARK). But as soon as I enter another character (as in a contraction), the apostrophe changes to a straight quote (U+0027 APOSTROPHE). This can only be saved by entering the symbol manually via the "Insert Special Characters" dialog.

This does not occur with any other fonts, only Alegreya Sans. I don't believe it's a bug in the font; the font's straight and curly quotes are at the correct Unicode points.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-16 19:15:41.285729

Comments

Confirmed - I've passed this message along to Huerta Tipográfica, and will update if there's any reply. It looks like @oweng has nailed the source of the problem, though.

David gravatar imageDavid ( 2013-12-30 13:34:55 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-12-30 03:23:24 +0100

oweng gravatar image

updated 2013-12-30 03:24:08 +0100

This is possibly due to the font itself (from examining the Regular weight) containing a replacement table (39) lookup of:

Base Glyph Name: quoteright (U+2019)

Replacement Glyph Name: quotesingle (U+0027)

edit flag offensive delete link more

Comments

Before I read your answer, I had contacted Huerta Tipografica, and they had confirmed this. Is there any way to disable this feature in LibreOffice?

Uglyface200 gravatar imageUglyface200 ( 2013-12-31 02:04:13 +0100 )edit

The replacement of U+0027 with U+2019 is standard word processor behaviour. The fact that this is not working for this particular font, would suggest to me that the font-level replacement overrides the application-level replacement. Sounds like that font has been designed to behave differently for a specific reason.

oweng gravatar imageoweng ( 2013-12-31 03:06:56 +0100 )edit

That's what I'm saying—Huerta Tipografica's designer said that he preferred it that way, and that I could fix the problem by disabling the OpenType feature "Standard Ligatures", and I'm asking how to do that.

Uglyface200 gravatar imageUglyface200 ( 2013-12-31 03:40:29 +0100 )edit

Oh sorry, I misunderstood. I think bug fdo#58941, which you point out in this thread, is the related enhancement to get this functionality exposed to the user.

oweng gravatar imageoweng ( 2014-01-03 12:33:54 +0100 )edit
1

Juan Pablo del Peral of Huerta Tipografica just emailed me saying that he's updated the font to remove this replacement table. So, problem solved.

Uglyface200 gravatar imageUglyface200 ( 2014-01-10 17:16:20 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2013-12-29 03:56:48 +0100

Seen: 399 times

Last updated: Dec 30 '13