Ask Your Question
0

How to change language for smart quote [closed]

asked 2014-01-09 12:29:38 +0100

l_lfc gravatar image

updated 2020-08-03 02:26:06 +0100

Alex Kemp gravatar image

When I type within a pair of English smart quote some Japanese characters, the ending quote automatically becomes Japanese and a different font face from the opening quote. In the worst case, it may even become ‘こんにちは」, where I can't resolve it even by changing fonts.

Is there a way to fix it?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 13:44:42.066810

1 Answer

Sort by » oldest newest most voted
1

answered 2014-01-09 13:41:46 +0100

ROSt52 gravatar image

updated 2014-01-09 13:45:57 +0100

Please let me ask first some questions:
- Which OS are you using?
- Which version of LibO?
- Which keyboard are you using?
- I assume you switch between Japanese and English - how do you switch?

Does this picture show what you want to get:

image description

Above is created in LibO 4.1.4.2 using English XP/SP3 with Asian support package. Japanese keyboard is used and IME entry method (入力方式). Switching between English and Japanese is done with the 半角・全角key.

edit flag offensive delete link more

Comments

I'm using Win7 Pro, LibO 4.1.3. For keyboard, I use Japanese and Traditional Chinese interchangeably, as for Trad. Chinese I have both the US Keyboard and Chinese input. I switch in a way that the icon of my Language Bar changes in between CH and JP. But the issue actually occurs even if I am typing English and paste Chinese/Japanese characters.

This is exactly what I get when I enable Smart Quote and type Japanese and Chinese in an English sentence: People in Asia may say “Hello” in “こんにちは』(Japanese) or “你好嗎』(Chinese).

I think the question is rather with the Smart Quote, as if I disable the Smart Quote I can get the quotes as what I have typed.

Thanks in advance!

l_lfc gravatar imagel_lfc ( 2014-01-12 11:04:04 +0100 )edit

In your example >> “こんにちは』<< where is the point when you switch to Japanese (Chinese)? After the >>"<< or before?

If you change before the >>"<< I feel you found a bug. Please report it under: https://www.libreoffice.org/get-help/bug/ it would be nice if you could publish the bug number/link here as well to enable other to add comments to the bug report.

ROSt52 gravatar imageROSt52 ( 2014-01-14 15:24:30 +0100 )edit

Sorry for taking so long to reply. Yes, I actually changed back to English before typing the >>"<<; actually I am hoping that to “こんにちは” rather than 『こんにちは』.

But anyway, I will try to make a report to see how it goes. Thanks a lot!

l_lfc gravatar imagel_lfc ( 2014-01-26 07:27:10 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-09 12:29:38 +0100

Seen: 188 times

Last updated: Jan 12 '14