We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

heading 5 shortcut key does not work

asked 2020-12-31 11:21:31 +0200

ROSt52 gravatar image

updated 2021-05-24 23:48:30 +0200

Alex Kemp gravatar image

Linux Mint 20 Cinnamon

LibO Version: 6.4.6.2 default version

The same error occurs in LibO 7.0.4.2

.

I am using plenty of headings in a Writer file and just needed to go for the first time to Heading 5 and found that shortcut ctrl+5 does not work, all others from 0-9 work fine. This in the aforementioned file, as well as in a new file created.

Going into Sidebar > Styles and double clicking Heading 5 works correct as well.

I checked Tools > Customize > Keyboard

ctrl+x (x=0-9) are shown as correct.

I wanted to re-do the setting for the shortcut key and entered in "Function" the search term "heading" while having in Category "All Commands" selected. Nothing showed up in the field Function.

Without a search term I scrolled through all entries in Function but "Heading...." did not show up.

I also checked Tools > Chapter Numbering. Also here everything looks correct.

Question: How can I get the shortcut key for ctrl+5 working again for Heading 5?

Thanks in advance for helping comments.

The following screenshot shows the selection of ctrl+5 for the style "heading 5". It was added after the kind answer of @ajlittoz and refers to my comment. Screenshot is valid for v7.0.4.2 and v 6.4.6.2

C:\fakepath\Screenshot_20210114_No01.png

(modified by ajlittoz to show the screenshot in the question)

edit retag flag offensive close merge delete

Comments

@ROSt52, I can confirm that by default there are Ctrl+n shortcuts assigned only for n between 1 and 5 in versions 6.4.7.2 and 7.0.4.2 (x86).

Ctrl+5 is not assigned to LibreOffice (see top right corner of image)? Have you tried it in safe mode?

LeroyG gravatar imageLeroyG ( 2021-01-14 15:43:06 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-12-31 11:45:56 +0200

ajlittoz gravatar image

In my 7.0.4.2, factory settings for Heading n are limited to levels 1-5.

Remember they are shortcuts for paragraph styles and therefore are not "commands".

In Category, expand Styles and select Paragraph. Function will then list the paragraph styles and you'll find the Heading n you can associate to a key.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

1

LibreOffice 6.4.7.2 also has Ctrl+n for n between 1 and 5.

LeroyG gravatar imageLeroyG ( 2020-12-31 12:06:26 +0200 )edit

@ajlittoz

Thanks for your reply. It clarified the "All commands" and "Styles", but is not yet the solution.

I checked "Styles" and it still ctrl+5 still does not work. See screenshot added to question. Note: sames situation for both versions.

I delete crl+5 and added it newly via the "Modify" button. Still it does not work Next I added "crl+A" to style heading 5 and this short cut key works in both versions.

Do we have a bug with ctrl;5?

I observe the same on a 2nd PC with the same installation of Linux Mint and LibO.

ROSt52 gravatar imageROSt52 ( 2021-01-14 03:07:04 +0200 )edit

I don't know how this key assignment works; it probably goes deep inside the OS, something like retrieving the raw keycode. This means it becomes keyboard-dependent.

I plugged a French keyboard to my machine. On such a keyboard, digits are accessed on the first row with Shift depressed. Then if I press Ctrl+Keypad 5, I get Heading 5. But Ctrl+Shift+( 5does not work (( 5` is what is engraved on the '5' key in the first row).

I can't select Ctrl+Shift+5 because it is disabled (grayed out). I see two reasons:

  • Shift+keypad don't return a digit but a navigation control (NumLock is configured by default on my machine)
  • shortcuts specify explicit modifiers and this may not be compatible with characters requiring a shifted key to be returned

Do digits require a modifier key on your keyboard?

ajlittoz gravatar imageajlittoz ( 2021-01-14 08:12:09 +0200 )edit

@ajlittoz

Again thanks for your reply. What you write about your AZERTY keyboard is pretty interesting.

As for my keyboard, I am using exactly the same keyboard since Libo v3.? and up to level 6,7 I used heading pretty often. I never saw this bug. It is Japanese keyboard, which is pretty much an QWERTY keyboard. No modifier key needed for numbers. Official name "Japanese (OADG 109A) keyboard.

Your comment about the keypad triggered an Idea. I used ctrl+number at the number keypad. And there all numbers work and give the correct heading level incl the 5. This together with my historical experience gives me the idea that we have a bug.

I will try to prepare a bug report once I tested v 7.1.0 to see if the bug exist there as well.

Thanks again for the fruitful discussion.

ROSt52 gravatar imageROSt52 ( 2021-02-18 14:43:05 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-12-31 11:21:31 +0200

Seen: 46 times

Last updated: Jan 14