Ask Your Question
0

URL Hyperlinks not working in writer 4.1.4.2 [closed]

asked 2014-01-19 21:34:47 +0100

Phylis Sophical gravatar image

updated 2016-02-18 17:30:21 +0100

Alex Kemp gravatar image

LibreOffice v. 4.1.4.2 Hyperlinks will not open when clicked on. Neither by Ctrl + click or not. I have checked / unchecked the option in Tools > Options > Security > Options and it will not work either way. Documents I have made in older versions of LibO will work. Calc links do work, just not Writer. AutoCorrect URL options are checked.

Is this a bug? Is a solution being worked on? OS: Windows 7

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 17:30:42.486922

Comments

I cannot confirm it. I use the prerelease LO 4.1.5 on Windows 7. When the cursor is in the hyperlink, the context menu should have a section about hyperlinks with the items "Open Hyperlink", "Edit Hyperlink" ... If you do not have this section, the hyperlink was not generated. If you have this section, try whether "Open" and "Edit" work.

Regina gravatar imageRegina ( 2014-01-19 23:47:57 +0100 )edit

I cannot confirm with my LO 4.1.4.2 on newly created files. Try this: Open the Navigator (View>Navigator, or F5). If you have hyperlinks they will be listed in the Hyperlinks section. Right-click on one of the hyperlinks in the Navigator and select Edit to bring up the Hyperlink dialog. You should see the hyperlink target and text. If not then maybe there is a bug and we need more information.

w_whalley gravatar imagew_whalley ( 2014-01-20 00:47:22 +0100 )edit

Thank you for your responses. Regina: There is no hyperlink to put my cursor in. Typing in an internet address just shows it as plain text.

Whalley: Navigator shows NO hyperlinks. But if I open a document made in a much older version of LO, links do show in Navigator with all options you mentioned.

I have found a work-around but I still want it to work automatically. - I type in the url. - Highlight it and click the 'Hyperlink' button. - Copy the url text into the 'Target' box, click 'Apply' and then I have an active hyperlink.

Phylis Sophical gravatar imagePhylis Sophical ( 2014-01-21 18:19:40 +0100 )edit
2

So your real problem is not "Hyperlink will not open" but the problem is "URL is not converted to hyperlink". Goto Tools > AutoCorrect Options > tab 'Options'. Make sure, that the option "URL recognition" is on. Then try again, write a URL, then a space. The typed URL should convert to a hyperlink.

Regina gravatar imageRegina ( 2014-01-21 19:33:56 +0100 )edit

Solved! And thanks Regina for the proper wording to my problem. Half the problem is knowing how to clearly state the problem, isn't it. The solution was: Format > Autocorrect > While typing. It was not checked. I'm new to this forum and not clear on protocol but I'm going to stick the solution in the 'Add answer' area as well. Happy to be corrected if I'm doing that wrong.

Phylis Sophical gravatar imagePhylis Sophical ( 2014-01-22 21:54:17 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-22 21:55:02 +0100

Phylis Sophical gravatar image

Format > Autocorrect > While typing

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-01-19 21:34:47 +0100

Seen: 2,162 times

Last updated: Jan 22 '14