URL Hyperlinks not working in writer

LibreOffice v.
Hyperlinks will not open when clicked on. Neither by Ctrl + click or not. I have checked / unchecked the option in Tools > Options > Security > Options and it will not work either way.
Documents I have made in older versions of LibO will work.
Calc links do work, just not Writer. AutoCorrect URL options are checked.

Is this a bug? Is a solution being worked on?
OS: Windows 7

I cannot confirm it. I use the prerelease LO 4.1.5 on Windows 7. When the cursor is in the hyperlink, the context menu should have a section about hyperlinks with the items “Open Hyperlink”, “Edit Hyperlink” … If you do not have this section, the hyperlink was not generated. If you have this section, try whether “Open” and “Edit” work.

I cannot confirm with my LO on newly created files. Try this: Open the Navigator (View>Navigator, or F5). If you have hyperlinks they will be listed in the Hyperlinks section. Right-click on one of the hyperlinks in the Navigator and select Edit to bring up the Hyperlink dialog. You should see the hyperlink target and text. If not then maybe there is a bug and we need more information.

Thank you for your responses.
Regina: There is no hyperlink to put my cursor in. Typing in an internet address just shows it as plain text.

Whalley: Navigator shows NO hyperlinks. But if I open a document made in a much older version of LO, links do show in Navigator with all options you mentioned.

I have found a work-around but I still want it to work automatically.

  • I type in the url.
  • Highlight it and click the ‘Hyperlink’ button.
  • Copy the url text into the ‘Target’ box, click ‘Apply’ and then I have an active hyperlink.

So your real problem is not “Hyperlink will not open” but the problem is “URL is not converted to hyperlink”. Goto Tools > AutoCorrect Options > tab ‘Options’. Make sure, that the option “URL recognition” is on. Then try again, write a URL, then a space. The typed URL should convert to a hyperlink.

Solved! And thanks Regina for the proper wording to my problem. Half the problem is knowing how to clearly state the problem, isn’t it. The solution was: Format > Autocorrect > While typing. It was not checked.
I’m new to this forum and not clear on protocol but I’m going to stick the solution in the ‘Add answer’ area as well. Happy to be corrected if I’m doing that wrong.

Format > Autocorrect > While typing

I am having this problem with LibreOffice Writer on Linux Mint.

Strangely, actual web URL links work fine, as do links to files on the same Linux box, however, links to Zotero items do not. They do not become active links in the Writer document, unlike the other two types of link.

The Zotero “select items link” has been working until today and links still open on LibreOffice on my Mac, although I now need to format the links manually. Prior to 6.4 the links were recognized by Writer automatically.

This is an example of an actual link to a Zotero item:

The Autocorrect setting does not solve the problem. I updated LO on Linux to the Fresh version and that did not solve the problem either.

LibreOffice version on Linux: Version:
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff

Linux Mint 19.3 Tricia
Kernel: Linux 5.3.0-53-generic
Architecture: x86-64

The LibreOffice on Mac which DOES open the Zotero item links is
Version: 6.4.2