Ask Your Question
0

Paste (⌘-v) doesn't work when pasting text string to Save As box

asked 2021-01-05 14:16:48 +0200

JMBaker gravatar image

updated 2021-01-07 19:23:02 +0200

I'm Working on a Macbook 2012, and I have a new Libre text document and I want to first save the document, and use a previously copied text string (from the clipboard) as the document name. But this doesn't work. My copied text string, no matter its length, does not paste in the "Save As" box.

Try it yourself: Highlight any text (using ⌘-C), and verify that it is on the clipboard. Now go to a new Libre text document and do Save As and try to paste (using ⌘-V) the clipboard contents as the new document name in the Save As Box. Why doesn't pasting text to the Save As box work? Very frustrating.. This works fine in MS Word...

Using LibreOffice v 6.1.5.2. See screen prints.

image description

image description

Update 7 Jan 2021. Thank you all for your suggestions and help. I have since upgraded LibreOffice to v 7.0.3.1, and pasting text to Save As box on a Macbook 2012 still does not work. See additional screens prints. I will file a bug report.

image description

Newly update LibreOffice: image description

edit retag flag offensive close merge delete

Comments

Works under Linux. Since the Save As dialog looks quite different (notably the Tags: text entry box), could it be an artefact of some MacOS customisation?

ajlittoz gravatar imageajlittoz ( 2021-01-05 14:29:51 +0200 )edit

Why doesn't pasting text to the Save As box work?

Please file a bug report to get a fix/answer. Users of LibreOffice may not be able to answer your "why" question founded on a possible bug.


PS Does not work on:

Version: 7.0.4.2, Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 4; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: en-US (de_DE.UTF-8); UI: en-US, Calc: threaded

as well (and for me it really looks like being a problem within LibreOffice; checked the procedure with other apps and these allow pasting)

Opaque gravatar imageOpaque ( 2021-01-05 14:41:17 +0200 )edit

WFM in LibreOffice 7.0.1 / Windows 7.

gabix gravatar imagegabix ( 2021-01-05 14:59:56 +0200 )edit

Are you using your OS save dialog? or LO's load/save dialogs? Check the options Tools/Options/LibreOffice/General and see if the Use LibreOffice Dialogs is selected. If not try with LO's load/save and see if there is a difference.

AdmFubar gravatar imageAdmFubar ( 2021-01-06 07:01:35 +0200 )edit

@AdmFubar

Please see my comment - @JMBaker is right and this does not work using LibreOffice on macOS and using operating system's save dialog (and it could be recognized from screenshot, that OP uses that)

Opaque gravatar imageOpaque ( 2021-01-06 12:13:10 +0200 )edit

@Opaque

Please reread my inquiry.. you missed something important.

AdmFubar gravatar imageAdmFubar ( 2021-01-06 19:15:01 +0200 )edit

@AdmFubar

of course you are right.

Opaque gravatar imageOpaque ( 2021-01-06 19:27:01 +0200 )edit

Thank you all for your suggestions and help. I have since upgraded LibreOffice to v 7.0.3.1, and pasting text to Save As box on a Macbook 2012 still does not work. See additional screens prints above. I will file a bug report.

JMBaker gravatar imageJMBaker ( 2021-01-07 19:23:35 +0200 )edit

According to tdf#126638 using the LO Dialogs as suggested by AdmFubar might work.

Earnest Al gravatar imageEarnest Al ( 2021-01-12 11:39:16 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-04-11 18:53:07 +0200

JMBaker gravatar image

updated 2021-04-11 18:55:25 +0200

This seems to fix the problem. Go to Preferences/LibreOffice/General. Select the "Use LibreOffice dialogs" box.

image description

edit flag offensive delete link more

Comments

This seems to fix the problem. Go to Preferences/LibreOffice/General. Select the "Use LibreOffice dialogs" box.

JMBaker gravatar imageJMBaker ( 2021-04-11 18:55:24 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-05 14:16:48 +0200

Seen: 56 times

Last updated: Apr 11