We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

Column Chart has thin bars - how to make columns/bars wider?

asked 2021-02-03 05:14:26 +0200

wsanders gravatar image

updated 2021-02-03 05:24:26 +0200

I can't find a way to make the bars on this chart wider, except by changing to a very thick line style. Is there a way to do this? The "spacing and "overlap" in "Data Series" seem to have no effect. (Ignore that one data item is selected in the picture; the "spacing" and "overlap" have no effect when the data series in selected.)

C:\fakepath\Screenshot_20210202_201226.png

edit retag flag offensive close merge delete

Comments

It looks like the Spacing parameter for the series is set very high, possibly the maximum (600%). Just reduce it.

JohnSUN gravatar imageJohnSUN ( 2021-02-03 09:06:01 +0200 )edit

Why there are a columns on the Y axis and oposite side? Why don't the bars coincide with the marks on the X axis? This don't happen normally with Columns chart type. Spacing to 600% gives a thicker column.

@wsanders, Have you saved the file as .xls(x)? Can you share a copy of your file to make some testing? To do that edit your question, and use the paper clip. Thanks.

LeroyG gravatar imageLeroyG ( 2021-02-03 13:15:46 +0200 )edit

Saving as XLS does not fix the formatting. "Spacing" and "overlap" are set at 50%, as I mentioned changing those parameters has no effect. The X label placement is automatic, I have just tilted the text 45 degrees.

wsanders gravatar imagewsanders ( 2021-02-03 18:12:56 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2021-02-03 19:11:45 +0200

wsanders gravatar image

updated 2021-02-03 19:16:55 +0200

Sort-of-solved: This happens when I assign "Categories" to the label the data series. Even if I remove all X-Axis labels, the hair-thin bars cannot be widened. When I delete the range spec from Categories, the bars are normal width. I have assigned categories to column/bar charts in the past without this problem, so we'll see if it's fixed in 7.0 and then I'll file a bug.

Workaround: Use a super-thick border line to outline the bars.

(My version is: Version: 6.4.7.2 Build ID: 6.4.7.2-5.fc32 CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3; Locale: en-US (en_US.UTF-8); UI-Language: en-US)

edit flag offensive delete link more
1

answered 2021-02-03 21:46:51 +0200

LeroyG gravatar image

See that you have multiple empty data series. So in Data Series you must remove them (in my sample, from Column B to Column J) only leaving the column with data (Column K in my sample).

image description

image description

image description

It is easy if you share a sample file. See my sample file.

Tested with LibreOffice 6.4.7.2 (x64); OS: Windows 10.0.


Add Answer is reserved for solutions. If you think the answer is not satisfactory, add a comment below, or click edit (below your question) to add more information. Thanks.

Check the mark (Answer markCorrect answer mark) to the left of the answer that solves your question.

If the answer helped you, you can mark the up arrow (Upvote mark) that is on the left (to vote, you need to have karma of at least 5).

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-02-03 05:14:26 +0200

Seen: 84 times

Last updated: Feb 03