Ask Your Question
0

Base: Connection was implicitly closed by the driver [closed]

asked 2012-05-25 20:40:02 +0200

RichA gravatar image

updated 2015-10-16 04:31:28 +0200

Alex Kemp gravatar image

In Base, when I connect to a remote MYSQL database using JDBC, I usually get to run one query okay, then the second query that I try gets "SQL Status: 08003 No operations allowed after connection closed.Connection was implicitly closed by the driver".

I then have to exit Base and restart it to run another query. I must be doing something wrong, but I don't know what. I believe I am using com.mysql.jdbc.driver, although I notice that when I look at Tools > Options >LibreOffice Base > Connections I do not see it in the list of drivers known to LibreOffice.

So...

What can I do to get rid of this continaul "connection implicitly closed by driver"?

In case I can't fix the above, is there any way to reconnect to the DB without exiting and restarting Base?

I am running on Ubuntu 11.04, and the following version of LibreOffice:

LibreOffice 3.3.4 OOO330m19 (Build:401) tag libreoffice-3.3.3.1, Ubuntu package 1:3.3.4-0ubuntu1

Thanks very much.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 04:31:42.418643

Comments

The following COULD be the cause of my problem: I went through the whole connection process again from scratch (that is, creating a new ODB). When I got to the point where the is a button to test the class com.mysql.jdbc.driver, it could not be loaded. (Though I could still connect okay.)

RichA gravatar imageRichA ( 2012-05-25 22:34:08 +0200 )edit

Downloading the mysql connector and adding it to my classpath...(it was there two weeks ago, what happened to it?)...did seem to improve things. I can stay connected for awhile, though I notice if I walk away for 10 minutes I will be disconnected.

RichA gravatar imageRichA ( 2012-05-25 22:57:59 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2012-05-28 21:15:54 +0200

RichA gravatar image

To fix the problem, add "?autoReconnect=true" (without the quotes) immediately after the name of the database (no intervening spaces).

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-05-25 20:40:02 +0200

Seen: 1,424 times

Last updated: May 28 '12