Ask Your Question
0

Libreofffice only opens as root [closed]

asked 2014-02-06 14:04:27 +0200

vfbsilva gravatar image

updated 2016-02-19 07:09:12 +0200

Alex Kemp gravatar image

Folks I'm using

ubuntu #46~lucid1-Ubuntu SMP Wed Jul 6 20:34:59 UTC 2011 i686 GNU/Linux and Libreoffice libreoffice (1:3.3.2-1ubuntu2~lucid1)

By some reason when I evoke ~$ libreoffice

the application hangs and no clue is given on the terminal. I've looked for a way to find a verbose mode to get some clue of what is going wrong. Extra info: I've tried to remove .libreoffice/ to see if it helps somehow but got no change on the application behaviour.

Running it as root seems to work.

Adding more info:

xchm works fine both from command line and menu launcher so I did: :~$ ls -l $(which libreoffice) -rwxr-xr-x 1 root root 53 2011-03-30 22:08 /usr/bin/libreoffice ~$ ls -l $(which xchm) -rwxr-xr-x 1 root root 371952 2009-11-08 00:25 /usr/bin/xchm :~$ xchm

Still only xchm works.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 07:09:36.463270

1 Answer

Sort by » oldest newest most voted
0

answered 2014-02-06 16:55:54 +0200

petermau gravatar image

On my Ubuntu 12.04 system, when using Terminal, I need to invoke libreoffice4.1 or libreoffice4.2 depending on the version I am using. These are the commands invoked if I use the icons. I install LibO by downloading them from the website.

Lucid and LibO 3.3.2 are a little old so I do not know whether my advice is still applicable. The program files are held in /opt/libreofficex.y/program, wwhere x.y are your version. Try running the /opt/libreofficex.y/program/soffice file.

How did you install LibO? Are the components not available through the Application/Office menus. If so, copy the command used there to invoke. Have you thought about updating LibO? LibO... Peter

edit flag offensive delete link more

Comments

I don't seem to have this files on this mentioned folders. I've installed Libreoffice through the company repositories. Yes Ive tried to update. But had no luck.

vfbsilva gravatar imagevfbsilva ( 2014-02-06 18:03:10 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-02-06 14:04:27 +0200

Seen: 1,002 times

Last updated: Feb 06 '14