Libreofffice only opens as root

Folks I’m using

ubuntu #46~lucid1-Ubuntu SMP Wed Jul
6 20:34:59 UTC 2011 i686 GNU/Linux
Libreoffice libreoffice

By some reason when I evoke
~$ libreoffice

the application hangs and no clue is given on the terminal. I’ve looked for a way to find a verbose mode to get some clue of what is going wrong. Extra info:
I’ve tried to remove .libreoffice/ to see if it helps somehow but got no change on the application behaviour.

Running it as root seems to work.

Adding more info:

xchm works fine both from command line
and menu launcher so I did: :~$ ls -l
$(which libreoffice)
-rwxr-xr-x 1 root root 53 2011-03-30 22:08 /usr/bin/libreoffice ~$ ls -l
$(which xchm)
-rwxr-xr-x 1 root root 371952 2009-11-08 00:25 /usr/bin/xchm :~$

Still only xchm works.

On my Ubuntu 12.04 system, when using Terminal, I need to invoke libreoffice4.1 or libreoffice4.2 depending on the version I am using. These are the commands invoked if I use the icons. I install LibO by downloading them from the website.

Lucid and LibO 3.3.2 are a little old so I do not know whether my advice is still applicable. The program files are held in /opt/libreofficex.y/program, wwhere x.y are your version. Try running the /opt/libreofficex.y/program/soffice file.

How did you install LibO? Are the components not available through the Application/Office menus. If so, copy the command used there to invoke. Have you thought about updating LibO? LibO… Peter

I don’t seem to have this files on this mentioned folders. I’ve installed Libreoffice through the company repositories. Yes Ive tried to update. But had no luck.