Numeric keypad and shift key

asked 2021-03-24 11:07:30 +0200

ajlittoz gravatar image

updated 2021-03-24 13:19:34 +0200

Tools>Customize allows to define keyboard shortcuts.

The numeric keypad can be used to alleviate the variation in national keyboards where the digits may require the use of the Shift key. Thus Ctrl+0 (via keypad) is always associated with Text Body without the need to press (or not) the Shift key on the main section of the keyboard.

I'd like to use the Shift key on the numeric keypad to be able to select "variants" of styles, i.e. Ctrl+0 would give Text Body and Ctrl+Shift+0 Default Character Style.

Unfortunately such key combinations are disabled (grayed out).

  • I know that Shift+NumKey is not at all a digit but an equivalent for cursor movement (and vice versa when NumLock is not active). In this case, should I associate my shortcut to Ctrl+Ins (= Shift+Num 0)? But this would conflict with some "movements" like Ctrl+ to move left to beginning of previous word.

  • Could it be that the OS itself or the active locale will not allow such combinations because of the dual functions on the numeric keypad due to the Shift key?

OS: Linux 5.11.7
Distro: Fedora 33
LO: 7.0.5.2

I don't think locale is relevant because I work under several locales and the key combination is grayed out in all.

EDIT

To make sure, I change the locale to en_US to make sure and rebooted the computer. The numeric shift combinations are still grayed out.

edit retag flag offensive close merge delete

Comments

Not grayed out for me. LibreOffice 7.0.4.2 (x86); OS: Windows 6.1.

image description

image description

Mayusculas if for Shift.

LeroyG gravatar imageLeroyG ( 2021-03-24 12:59:58 +0200 )edit

No hablo español con fluidez pero puedo leerlo ;-)

ajlittoz gravatar imageajlittoz ( 2021-03-24 13:07:20 +0200 )edit

Are those shortcuts not already associated with LibreOffice? Not for me.

LeroyG gravatar imageLeroyG ( 2021-03-24 14:57:20 +0200 )edit

The Ctrl+Num are preset as for you and I can change them. But Ctrl+Shift+Num are grayed out. I can't even use predefined Ctrl+Shift+`0. I would like to change this one to Default Character style which I use much more. I never use Default Paragraph Style because I format exclusively with styles.

ajlittoz gravatar imageajlittoz ( 2021-03-24 15:05:18 +0200 )edit

I can change Ctrl+Shift+0 to Default Character, but only works with the numbers in the alphanumeric top row.

Ctrl+Shift+numpad 0 = Ctrl+Insert.

Why not Ctrl+Alt+Num?

LeroyG gravatar imageLeroyG ( 2021-03-24 15:16:20 +0200 )edit

Sometimes people get very tired and do not see the obvious! I have no particular preference for Shift and Alt or Ctrl+Alt will do equally well (these combinations are not grayed out).

But anycombination with Shift+Num on the keypad will not work. Ctrl+Alt+Shift is not grayed out, nor Alt+Shift, but no luck on the keypad.

So, I'll use another modifier but I'd like to know why Shift does not work. Is this because the Shift modifier has already been intercepted by the OS to manage both modes of the keypad?

ajlittoz gravatar imageajlittoz ( 2021-03-24 16:16:17 +0200 )edit