We're currently migrating from Ask to Discourse, read the details here

Ask Your Question
0

how to solve particular list need in style with features

asked 2021-03-31 13:40:22 +0200

pippopa9 gravatar image

updated 2021-04-22 00:47:57 +0200

Alex Kemp gravatar image

Hi.

I have a particular request for a problem that I would like to solve using the Libreoffice Writer features automatically, without making the repeated manual changes that a novice user would do.

I created a style called Summary. When I write within paragraphs associated to the Summary style I need that

  • every time I click the list button to create a new one it has a numbering 1,2,3 and has no horizontal indentation
  • each list must continue with the numbering concluded in the previous paragraph Summary
  • occasionally, I can manually change the numbering, for example although the previous paragraph Summary ended with an element that had the number 46, I can in the next paragraph restart (manually) from 49 instead of 47
  • all this must happen only within the Summary style

I hope I have explained well. Of course there are several possible ways, but I would like to know which is the best approach to take, that is the one that saves me time and does a job brilliantly.

Thank you very much

---- Edit Apr 11, 2021 ----

I have a new need. I have written several acts from 1 to 36, all regularly in this sequence

[archival reference]
[act summary] (with style called Summary, automatically numbered)
[Description]

Now I have to insert two acts that I need to (manually) enumerate 36A and 36B (or 36a and 36b) whose relevant contents must also appear in the alphabetical index (you can understand better by reading my other question https://ask.libreoffice.org/en/questi... ). Then I will restart with number 37.

What is the method that libreoffice offers me?

---- Edit Apr 12, 2021 ---

Also consider that each act summary is level 3. At the beginning of the book there is an index of acts (this is a TOC) in which I show all the summaries

1. [act 1 summary]
2. [act 2 summary]
...
36. [act 36 summary]
36A. [act 36A summary]

My need is to show the list as above. I tried to define a "Summary (2nd level)" style for the management of level 4 with numbering A, B, C ... and then modified the aforementioned TOC so that it collects not only level 3, but also level 4. Very well, it works, but the problem is that in the summary after 36 appears A and not 36A. Are there other avenues that meet my need?


Here you can find a sample of my work. The book is written in italian, just go to Protocollo 1. Look at the sequence 1,2,3 (regular - "Sommario atto" style - level 3) and after A, B ("Sommario atto 2nd level" style - level 4). Then normally to act #4 C:\fakepath\sample for forum.odt

Thanks a lot

edit retag flag offensive close merge delete

Comments

Since your design is a bit unconventional, attach a 1- or 2-page sample to your question (use the paperclip tool) so that I have a clear understanding of your styles and hierarchy.. Getting 36A instead of A is a matter of tuning numbering, but I am a bit lost in your usage of levels.

ajlittoz gravatar imageajlittoz ( 2021-04-12 12:46:30 +0200 )edit

just uploaded

pippopa9 gravatar imagepippopa9 ( 2021-04-12 14:00:32 +0200 )edit

Just quick preliminary observations before answering:

  • why did you use the toolbar button to create your numbered list? This direct formatting method has many defaults, notably in your case of non-contiguous list. Faultless funing formatting becomes more hazardous.

  • why did you use level 3 for the list items? They are not nested inside another list. Lists are totally independent from chapter numbering. Even if your "Protocollo 1" is a Heading 2, primary list items can (and should) be at list level 1 (because there is no relation between headings and lists).

Apparently, you messed the list hierarchy by assigning your "A" to level 1 while the "55" is at level 3.

ajlittoz gravatar imageajlittoz ( 2021-04-12 15:10:23 +0200 )edit

In my book I used level 1 (Heading 1) for the book title. Level 2 (Heading 2) for chapters. Some chapters ("Protocollo 1", 2 and 3) contain the acts, which have an independent numbering, this is necessary to solve another aspect I've explained here https://ask.libreoffice.org/en/questi... a-different-numbering-than-pages /

In the attachment I have reduced the text with the intention to semplify life for people have to help me. So act #55 became act #3. Acts #55a and #55b must become #3a and #3b. Then there will be act #4.

I would like to know what I did wrong, or what is the system to adopt. Thanks again.

pippopa9 gravatar imagepippopa9 ( 2021-04-12 18:39:15 +0200 )edit

Unless you want the book title in the TOC, Heading 1 is intended for chapter headings. Book title has a dedicated paragraph style named Title.

Checking and debugging your sample file was quite long. See my (lengthy) answer and study the revised sample.

ajlittoz gravatar imageajlittoz ( 2021-04-12 19:07:40 +0200 )edit

First of all, I thank you for the time you have dedicated to me, but I suggest you limit yourself to the problem I am presenting to you, don't look at everything, it's not necessary. Regarding the setting of the first page, for example, I'm not interested in defining a style that I use only once in all book, I do it manually without styles. Maybe some things I will understand in the future, I have only been using Writer for a few weeks.

I downloaded your attached file a few hours ago and I have to tell you that even now I don't understand how you managed to create 4.A and 4.B after 3. I can't reproduce it in my book. Looking at my sample file, actually I need that after 3 there are 3.A and 3.B (not 4.A ...(plus)

pippopa9 gravatar imagepippopa9 ( 2021-04-12 21:19:40 +0200 )edit

I add this comment to clarify that I appreciate your help, but in my opinion you should review what you've done, because in my sample file (with poor settings but works for me) I've achieved results that I don't intend to lose. Please, restart from my sample and solve only point 4, rest is ok.

Let's go in order.

  1. In standard TOC called "Indice" you have entered the links that I don't want.

  2. In TOC called "Indice dei regesti" I must have a trivial list made like this:

    1. summary act #1
    2. summary act #2 ... (You have reviewed this TOC and introduced links that I don't want)
  3. Each act description is preceded by a few lines with a gray border on the left. You have entered a space, the border isn't continuous as before.

  4. I asked you to have act 3A and 3B (or ...

(plus)
pippopa9 gravatar imagepippopa9 ( 2021-04-13 00:11:59 +0200 )edit
  1. I didn't intentionally modified your "indice" TOC. This is likely the consequence of my investigation when I righ(-clicked on it to Edit Index. My default settings may have done this addition. Apologies.

  2. I did extensive changes in "Indice dei registri" and again I suppose my default settings came into play.

It is quite easy to fix: delete LS and LE in the structure lines.

However, are you sure you didn't create the hyperlinks? I downloaded again the sample file and the hyperlinks are already there. This may be a by-product of the preparation of the sample file on your side.

ajlittoz gravatar imageajlittoz ( 2021-04-13 10:14:51 +0200 )edit

Point 3

Border merging is quite erratic in Writer. It looks like border attributes are not well inherited by dependent styles (thanks for making me learn this aspect). The slightest difference in the settings causes the borders to be separated by a non configurable space.

I worked again on the styles and the issue is fixed. Due to this unspecified behaviour, you need to tune both Sommario regesto and Riferimento atto, though the latter is a descendant of the former (adjusting the border in the ancestor should be sufficient). I think this is a bug. I'll report it when I have time to characterize it.

ajlittoz gravatar imageajlittoz ( 2021-04-13 10:27:01 +0200 )edit

Point 4

Your specification was not clear on this requirement and I didn't understand the act numbers. Your sample has an act 3 and requests creation of acts 55a and 55b.

Anyway, I just remove the dummy hidden paragraph and this should give what you intend.

By the way, enable View>Formatting Marks and Tools>Options, LibreOffice Writer>ViewHidden text and Hidden Paragraphs in Display fields to be able to see on screen (it does not change printing) the tricky formatting if you haven't yet enabled them.

ajlittoz gravatar imageajlittoz ( 2021-04-13 10:40:28 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2021-03-31 14:14:55 +0200

ajlittoz gravatar image

updated 2021-04-12 19:03:50 +0200

Automatic lists is the most difficult feature to configure in Writer because it involves two style categories: a paragraph style and a list style (in fact a counter definition). But, once set up, you no longer use the list button, otherwise you mess up your setting.

You already have defined your Summary paragraph style. You must associate it with a counter. Open your Summary definition and go to the Outline & Formatting tab. In section *Numbering, select from *Numbering style drop-down menu Numbering 123. OK

This has the effect to assign the Numbering 123 list style to your Summary paragraph style.

Every paragraph so styled will have automatically a list item number.

To tune the formatting of the items (with regard to indents), you must modify the list style and not the paragraph style because the list style settings take precedence over those of the paragraph style. List styles are listed in the side style pane (F11 if not yet visible) by clicking on the fifth icon in the toolbar.

Right-click on Numbering 123 and Modify. The settings are in Position and Customize tabs.

CAUTION! Don't play with BulletsImage tabs because they ruin what you have set in the aforementioned tabs and you'll have to start over again.

How to use Summary?

When you want to type a list item, just style the paragraph Summary. Don't use the list button.

If you follow the recipe above in an existing document where you have already Summary paragraphs with List button added, remove first the effect of the List button otherwise Writer will get confused and you won't be able to format your list.

Notes:

Numbering 123 is now associated with Summary and should not be used with other paragraph styles. Numbering 123 defines one list; So unless other paragraph styles are only stylistic variations of Summary intended to be part of the same list, avoid multi-association or you'll be disconcerted by the result.

To get occasionally unnumbered list items, put the cursor at the very beginning of the item (just after the auto number) and hit Backspace key.

You can't have holes in the numbering sequence. All you can do is restart from 1.

This will work fine as long as you save .odt. Don't save .doc(x) because Word has no notion of list styles and you will lose your definition after a round trip.

Answer to additional need

Any list is multi-level, i.e. it behaves the same as chapter numbering (the underlying device is the same). Therefore, to get "37A" you force your list item to level 2 by typing a Tab at start of its text.

If you later change your mind and want to revert to level 1, put the cursor at the very beginning of the item and press Shift+Tab.

You need to customize the list style to number alphabetically level 2. Right-click on Numbering 123. In Options, select level 2 and set Number to A ... (more)

edit flag offensive delete link more

Comments

Very good, this is what I wanted. I cannot upvote because I don't have enough points.

pippopa9 gravatar imagepippopa9 ( 2021-03-31 21:06:26 +0200 )edit

You now have enough karma to upvote.

ajlittoz gravatar imageajlittoz ( 2021-04-12 08:04:05 +0200 )edit

In the meantime, thank you for your reply. However, I don't get what I need. I've added more information to my main post. Thanks!

pippopa9 gravatar imagepippopa9 ( 2021-04-12 12:25:32 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2021-03-31 13:40:22 +0200

Seen: 58 times

Last updated: Apr 12