Ask Your Question
0

Problem with Arabic language and Book numbering [closed]

asked 2014-02-21 16:11:45 +0200

OssNass gravatar image

Hello
My problem is this :
When I try use book numbering in arabic I get a problem
In English the book numbering goes like this :
1.2.3.4 = Chpater 1, Paragraph 2 , subparagraph 3 ... etc
But when I switch to Arabic (which is a Right to left language) then the numbering must look like this :
4.3.2.1 = Chpater 1, Paragraph 2 , subparagraph 3 ... etc
But it doesn't, instead it looks like as in English
Any tips ?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 11:26:09.053792

1 Answer

Sort by » oldest newest most voted
1

answered 2014-02-21 21:31:54 +0200

Waraqa gravatar image

updated 2014-02-22 18:54:32 +0200

Unfortunately, This is a bug in libreoffice which causes separated numbers to appear Left To Right even If you are using RTL direction. It appears also in:

  • Date: 22/2/2014 The result should be reversed in RTL (2014/2/22)
  • Dot separated nubmers (Your problem)
  • Dash separated numbers (1-2-3-4)
  • Plus separated nubmers (1+2+3+4)

    etc..

Update:

The only workaround I know is to change the separator (Edit - Fields) to a character that doesn't have the bug. If you need to keep the same separator (dot), You can choose another dot from Unicode map such as U+2024 ( ․ ). (Credit to Safa from #LinuxAC who just discoverd this character)

If you have this problem in other cases, You can simply insert a space before or after the separator.

edit flag offensive delete link more

Comments

Is there a way to work around it ?

OssNass gravatar imageOssNass ( 2014-02-22 08:31:15 +0200 )edit

I have updated the answer with a workaround.

Waraqa gravatar imageWaraqa ( 2014-02-22 11:36:36 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-02-21 16:11:45 +0200

Seen: 305 times

Last updated: Feb 22 '14