Ask Your Question
0

[SOLVED] How to switch off automatic subscript and superscript ?

asked 2021-04-06 20:57:34 +0200

User555 gravatar image

updated 2021-04-07 14:33:17 +0200

Hi !

By default, when something like ^a or _a is written after a word, the ^ or the _ disappears and the next character becomes superscript or subscript. I find it really annoying; is it possible to switch it off ?

Thanks !

EDIT :

OS : GNU/Linux, Debian buster

LibreOffice version : 6.1.5.2

Actually (I didn't notice), this behavior occurs only with numbers (only for ^2 and _2, for example).

edit retag flag offensive close merge delete

Comments

Hello @User555, Can you share your operating system and LibreOffice version? To do that, choose menu Help - About LibreOffice, copy from there, press edit below your question and paste.

When Replace is activated, :^a: is for superscript a, and :_a: is for subscript a. To deactivate this option choose menu Tools - AutoCorrect - AutoCorrect Options… - Options tab, and uncheck Use replacement table.

See replace list in Tools - AutoCorrect - AutoCorrect Options… - Replace tab.

LeroyG gravatar imageLeroyG ( 2021-04-06 22:12:02 +0200 )edit
2

By default, when something like ^a or _a is written after a word, the ^ or the _ disappears

AFAIK that's only a default in Math (Formula editor), where it is part of the syntax.

Opaque gravatar imageOpaque ( 2021-04-06 23:22:06 +0200 )edit

Thanks for your quick answers !

@LeroyG : I've added my OS and LibreOffice version.

Indeed, unchecking "Use replacement table" works, but the problem is … it completely disables the replacement table, which I actually use ^^.

I've also deleted all the rules like :_a: or :^a:, in the replace list, but that doesn't work (the problem happens without the ":").

@Opaque : You seem to be right about letters : ^a actually doesn't turn into a superscript in Writer and Calc (I don't know why I didn't check that before).

But it does happen with numbers : ^2 becomes ², for example.

User555 gravatar imageUser555 ( 2021-04-07 08:16:00 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2021-04-07 14:00:12 +0200

LeroyG gravatar image

You must delete the .*^0 and .*_0 (and for 1 to 9) in the Replace list (in Tools - AutoCorrect - AutoCorrect Options… - Replace tab.).

edit flag offensive delete link more

Comments

It works, thanks !

User555 gravatar imageUser555 ( 2021-04-07 14:31:49 +0200 )edit
0

answered 2021-04-06 21:58:07 +0200

Wanderer gravatar image

You find the options under autocorrect. Help page

You can completely switch autocorrect off or single features.

J.

edit flag offensive delete link more

Comments

Not documented there.

LeroyG gravatar imageLeroyG ( 2021-04-06 22:12:38 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-04-06 20:57:34 +0200

Seen: 52 times

Last updated: Apr 07