[SOLVED] How to switch off automatic subscript and superscript?

Hi !

By default, when something like ^a or _a is written after a word, the ^ or the _ disappears and the next character becomes superscript or subscript. I find it really annoying; is it possible to switch it off ?

Thanks !


OS : GNU/Linux, Debian buster

LibreOffice version :

Actually (I didn’t notice), this behavior occurs only with numbers (only for ^2 and _2, for example).

Hello @User555, Can you share your operating system and LibreOffice version? To do that, choose menu Help - About LibreOffice, copy from there, press edit below your question and paste.

When Replace is activated, :^a: is for superscript a, and :_a: is for subscript a. To deactivate this option choose menu Tools - AutoCorrect - AutoCorrect Options… - Options tab, and uncheck Use replacement table.

See replace list in Tools - AutoCorrect - AutoCorrect Options… - Replace tab.

By default, when something like ^a or _a is written after a word, the ^ or the _ disappears

AFAIK that’s only a default in Math (Formula editor), where it is part of the syntax.

Thanks for your quick answers !

@LeroyG :
I’ve added my OS and LibreOffice version.

Indeed, unchecking “Use replacement table” works, but the problem is … it completely disables the replacement table, which I actually use ^^.

I’ve also deleted all the rules like :_a: or :^a:, in the replace list, but that doesn’t work (the problem happens without the “:”).

@anon73440385 :
You seem to be right about letters : ^a actually doesn’t turn into a superscript in Writer and Calc (I don’t know why I didn’t check that before).

But it does happen with numbers : ^2 becomes ², for example.

You must delete the .*^0 and .*_0 (and for 1 to 9) in the Replace list (in Tools - AutoCorrect - AutoCorrect Options… - Replace tab.).

It works, thanks !

You find the options under autocorrect.
Help page

You can completely switch autocorrect off or single features.


Not documented there.