Ask Your Question
0

Solved -LibreOffice 4.1.5 - Error - not open network files [closed]

asked 2014-02-26 14:31:58 +0100

gegon69 gravatar image

updated 2015-08-29 15:22:29 +0100

Alex Kemp gravatar image

LibreOffice 4.1.5.3 (linux -Ubuntu 12.04) -Error -not open network files (samba) using nautilus. I installed this version by downloading the files from the libreoffice website and installed using sudo dpkg-i *.deb (As I always do)

Too when I install LibreOffice 4.1.5.3 using ppa, I get error when opening network files .ods .odt

This error is very serious for a recommended version for all users.

LibreOffice 4.2.1 is targeted for early adopters and private power users.

I do not want more surprises ...I return to my old familiar LibreOffice 4.0.6

Solved (LibreOffice 4.1.5 - Ubuntu 12.04 ):

After installing LibreOffice 4.1.5, put in the terminal:

sudo sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/share/applications/libreoffice*

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-06 18:11:10.474396

Comments

Report a bug against 4.1.x using bug tracker. Also try installing 4.2 and if problem still appears report a bug. Bugs do not get fixed if there are not reported. Also 4.0 is fine if it is working for you, but it is at the end of life status: https://wiki.documentfoundation.org/ReleasePlan and 4.1 is also approaching end of life in end of April.

L-user gravatar imageL-user ( 2014-02-27 08:09:12 +0100 )edit

Also if you would really like to solve the problem it would HELP A LOT if you could install 4.1.1 and see if the problem appears, if not install 4.1.2, then 4.1.3, then 4.1.4 and finally 4.1.5 - until a problem appears. To get the first problematic version it dramatically reduces the time for developers to track down which of the update created your problem.

L-user gravatar imageL-user ( 2014-02-27 08:10:49 +0100 )edit

It seems that this error is only for Ubuntu 12.04, using LibreOffice 4.1.x or 4.2.x. Several people reported this error. I guess it's caused by old versions of GNOME\Samba libs. I found no solution.

gegon69 gravatar imagegegon69 ( 2014-02-27 17:10:44 +0100 )edit
gegon69 gravatar imagegegon69 ( 2014-02-27 22:07:33 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2014-02-26 14:37:55 +0100

L-user gravatar image

updated 2014-02-26 19:58:20 +0100

I know there were some problems opening network files. The work around is to copy network file to local disk, work with the file in LibreOffice and then save back to network drive.

Edit: You may try to install latest stable 4.2.x on one of the PCs to see if this problem is already fixed. For Ubuntu follow the following tutorial: http://ask.libreoffice.org/en/question/30365/libreoffice-4-2-ppa-for-ubuntu-1204-1310-how-to-install-tutorial/

edit flag offensive delete link more

Comments

Thank you very much for your answers!

gegon69 gravatar imagegegon69 ( 2014-02-26 23:35:20 +0100 )edit

Moving back to 4.0 if you really need stable environment is wise to do. But on the other hand I still suggest to install LibreOffice 4.2 on one of the test PC and test if this problem is fixed. If not then I suggest to report a bug to bug tracker. You may be having a unique problem and if so it will not going to be fixed without a bug report: https://www.libreoffice.org/get-help/bug/

L-user gravatar imageL-user ( 2014-02-27 08:00:47 +0100 )edit

Also, refer this answer for GVFS-related issue and workaround.

oweng gravatar imageoweng ( 2014-02-27 23:46:38 +0100 )edit

Thank you very much! After installing LibreOffice 4.1.5, put in the terminal:

sudo sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/share/applications/libreoffice*

gegon69 gravatar imagegegon69 ( 2014-03-05 22:11:05 +0100 )edit
0

answered 2014-11-28 02:22:42 +0100

Gael gravatar image

updated 2014-11-28 02:25:24 +0100

Thanks Gogon69

I did like you said (the sed command)

I modified all files in /usr/share/applications/libreoffice*

Commented out the "X-GIO-NoFuse" property and it fixed my problem. Now, I can open network files :D

I'm surprised that the bug hasn't been fixed yet (LibreOffice 4.3.4)

Any idea what that "NoFuse" does??

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-02-26 14:31:58 +0100

Seen: 4,739 times

Last updated: Nov 28 '14