[Solved] Open ods or odt files from a smb share throws damaged file error

Hi there,

Opening xls, csv files with LO is not a problem. Opening ods, odt files from .gvfs mount point also open up fine.
The problem is that Nautilus will follow the symlink inside the .gvfs folder to transform it back to smb://server and LO complains that the file is corrupted. (It is not, if I copy the file to home folder it will open up fine). It I choose to repair the file, a LO Math opens up an empty file. If I choose not to repair the file, LO gets stuck in a loop asking all the time if I want to repair it.

I did some reading and came up with different opinions wheter the problem is file locking, some gvfs-fuse problem and other non working solutions.

Currently I’m using LO 4.1.1 on a Xubuntu 12.04

I rely on this smb share, I can’t change it to NFS or whatever. Any help appreciated.



I’ve been having the same problems. I’m using Ubuntu 13.04, with LO 4.1.1. and it will not open any word, calc or base file over a GVFS share mount, I have to copy it to my desktop and open it from there.
From another computer, Ubuntu 13.04 and LO, I am able to open files but occasionally get corrupt files - sometimes they are not really corrupt (opens from the computer holding the files) but other times the file does become truly corrupted and non-recoverable.
No solutions yet,

GVFS has long has problems under LO. I remember reading on the Dev mailing list why this is but I can’t remember the cause now. There are numerous questions on this forum about problems accessing files on Samba shares. I provide a summary of some of them here. Related bugs include:

  • fdo#56544, lock files on Samba shares Resolved for v5.0.6, v5.1.2, and v5.2.0. Refer related thread
  • fdo#58052, ucpgvfs1.uno.so fails to load
  • fdo#59424, I/O Error while opening file from WebDAV over GVFS from Nautilus
  • fdo#67527, LO can’t open files over SMB - wants to repair!

It has been suggested here that the last bug contains a workaround in comment #15, and an easy way to apply this is:

sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/share/applications/libreoffice-*

Obviously the path used in the example should be changed according to your install location.

EDIT: Comment #59 in the last bug provides further information, which I will quote here:

The repair dialog is an Ubuntu 12.04 specific bug, related to glib package. See https://launchpad.net/bugs/1214352

The problem with KDE is another problem, mostly related to missing packages:

  • For the build from distro repositories, you should also install ‘gvfs’ and ‘gvfs-smb’ packages for Fedora, or ‘gvfs’, ‘gvfs-backends’, ‘libreoffice-gnome’ for Ubuntu.
  • For the build from libreoffice.org, you should also install ‘gnome-vfs2’, ‘gnome-vfs2-smb’, ‘ORBit2’ for Fedora, or ‘libgnomevfs2-0’, ‘libgnomevfs2-extra’, ‘liborbit2’. You should also export ‘OOO_FORCE_DESKTOP=gnome’, otherwise it won’t work.


Thank you so much! (And: the path matches my system Xubuntu 12.04 - great)

Thank you so much!!!

After installing LibreOffice 4.2.1 (or 4.1.5) on Ubuntu 12.04, put in the terminal:

sudo sed -i ‘s/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/’ /usr/share/applications/libreoffice*

Worked for me too! On Ubuntu 14.04 and LO 4.3.3

When opening files from nautilus then, I get the following error: “error when accessing /run/user/1001/gvfs/dav:host=…,ssl=true,prefix=…”

GVFS has generally been troubling, usually causing high CPU usage for mostly nothing.

Ubuntu 18.04, Minimal Install, Ubuntu Software add LibreOffice Calc, requires manual ‘sudo apt install libreoffice-gnome’.

Thank you oweng!
I’m unsure where to head to just to say “me too” in order to get this bug fixed. Bug 67527 seems to match. Any advice?

Thanks again.

The usual place is in the bug itself, but in honesty there is already a lot of interest in this bug, so unless you have something constructive to contribute I would suggest giving it a miss. You can however add yourself to the CC list in the bug so you are kept informed of any developments. It appears to be a regression in the LO v4.1 series so will likely be fixed before long.

Understood. Thanks again!


same problem

Instale desde repositorio devuan libreoffice-gnome y funciona
i’m install from repos devuan libreoffice-gnome, now works