Ask Your Question
0

PDF-Export going wrong! [closed]

asked 2021-04-16 18:49:44 +0200

michael_stellpflug gravatar image

I installed LibreOffice 7.0.5.2 on Lubunutu (Kernel 5.4.0 64bit). When I export my document or try to print it, the text is missing! Only the pictures are exported. This problem was reported in the Ubuntu Wiki, where they suggest to change the VCL from qt5 to kf5.as explained in https://wiki.ubuntuusers.de/LibreOffi...

But when I do this, LibreOffice is not starting properly any more. I have no solution to this problem for this version! For LibreOffice 6.4 this bugfix worked. Any ideas? Now I cannot use the program any more without properly printing and PDF-Export it is worth nothing. Regards, Michael

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by PKG
close date 2021-04-17 12:14:48.739963

Comments

Although LXQt (the LUbuntu desktop manager) is based on Qt, I'm not sure that package libreoffice-kf5 will solve the problem because kf5 stands for "KDE Frameworks 5" meaning there is a KDE layer above Qt. Also when you install kf5 you must make sure libreoffice-qt5 is uninstalled to avoid conflicts. To make sure it is an issue with the desktop manager, install libreoffice-x11 (uninstalling other -qt5 or -kf5 packages). The UI will be horrible but if this fallback works, it will tell the problem is with the graphics interface.

ajlittoz gravatar imageajlittoz ( 2021-04-16 19:10:48 +0200 )edit

If you try with VCLPLUGIN=gen, does it work?

To show the community your question has been answered, please tag the best answer (), and/or vote for any helpful answer. Else, please edit your question to add information (answers are for solutions only).

Hagar Delest gravatar imageHagar Delest ( 2021-04-16 19:12:21 +0200 )edit

I installed LibreOffice 7.0.5.2

From where - from Ubuntu PPA or from libreoffice.org (TDF packages)?


Lubunutu (Kernel 5.4.0 64bit).

Which Lubuntu release? - Kernel 5.4.0 sounds a bit like Lubuntu 20.04 and if that's the case then


When I export my document or try to print it, the text is missing!

reminds me to question https://ask.libreoffice.org/en/question/242188/cannot-print-anything-exporting-to-pdf-produces-blank-pdf-lubuntu-2004/ - check the answer therein (I'm aware you are already using 7.0.5 - try the solution anyway)

Opaque gravatar imageOpaque ( 2021-04-16 19:33:35 +0200 )edit

Thank you, but it still doesn't work!

michael_stellpflug gravatar imagemichael_stellpflug ( 2021-04-16 22:54:21 +0200 )edit

Thanks for your help! I installed it from LibreOffice.org. The Link that Opaque sent seems promising! I will try that soon!

michael_stellpflug gravatar imagemichael_stellpflug ( 2021-04-16 22:54:50 +0200 )edit

I've changed my answer in comment since it doesn't work (your comment does not refer to that anymore but no big deal). Indeed, Opaque's link may be better.

Hagar Delest gravatar imageHagar Delest ( 2021-04-16 23:00:52 +0200 )edit

Thank you Opaque, that worked! LibreOffice now looks diffrently and is able to export to PDF. The only strange thing is that it does not appear in the start menu. I always have to start it via command line. Only LibreOfficeBase appears as an Icon in the start menu. LibreOffice now runs with gtk3 as VCL.

michael_stellpflug gravatar imagemichael_stellpflug ( 2021-04-17 10:03:57 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-04-17 11:31:57 +0200

michael_stellpflug gravatar image

updated 2021-04-17 12:10:11 +0200

ajlittoz gravatar image

So the solution to my question is the procedure described here: 242188/cannot-print-anything-exporting-to-pdf-produces-blank-pdf-lubuntu-2004

(link reformatted by ajlittoz to make it more descriptive)

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2021-04-16 18:49:44 +0200

Seen: 53 times

Last updated: Apr 17