Cannot print anything, exporting to PDF produces blank PDF (Lubuntu 20.04)

I am using Lubuntu 20.04 and cannot get LibreOffice to print anything at all correctly. Either it prints blank pages, or some garbage (random [?] characters). Exporting to PDF usually the same; some PDF reader programs show errors. When opening the PDF document in a text editor, I found the following text:

% CreateFontSubset failed for font
“Liberation Sans” weight=5

% CreateFontSubset failed for font
“Liberation Sans” weight=8

The font names and wights vary, depending on which fonts are used in the document.

It seems that previously, someone else had the same issue - however, the link leads to an error page. :frowning:

I tried the version shipping with Lubuntu 20.04, I tried and directly from - the issue remains the same.

Printing from any other software - including OpenOffice 4.1.7, which I installed despite preferring LibreOffice - works fine.

Any ideas?



I could fix that on my test system using the following procedure:

Completely remove anything related to LibreOffice

  • dpkg --list | awk '/ii/&&/libreoffice/||/libobasis/{print $2}' | sudo xargs apt purge -y ure
  • sudo apt autoremove -y
  • sudo rm -r /usr/lib/libreoffice/*

Note: Don’t care about libobasis appearing here. I do use the command regularly to de-install TDF packages as well


  • sudo apt install libreoffice

May be this will help you as well.

Thank you very much! This works for me, too!
I have no clue why as it was a fresh Lubuntu installation (no upgrade) that didn’t work. OK, I kept my old user config files - but I still use them, and now it works…

If the answer helped to solve your problem, please click the check mark (:heavy_check_mark:) next to the answer.
[Update] Thanks for considering my comment(s) :slight_smile:

I had a similar problem. Install of LO under Lubuntu 20.04. Each time I printed all I got was:

PDF Error 118: Resource Not Found
Resource not found:/F1

Problem seen on two separate systems

Above instructions worked a treat - all now working fine. Thanks for the solution! (wish I knew what had caused the problem though…)

@ListerofSmeg - this must be a problem of initial installs of LibreOffice on Ubuntu 20.04 based systems - see also Lubuntu 20.04, LibreOffice My Samsung ML 1610 printer does not print text correctly through LibreOffice. It prints graphics correctly

this is completely enough:

sudo apt remove libreoffice-qt5

in Lubuntu 20.04.1 those 2 lines are completely enough:

sudo apt install libreoffice-kf5

sudo apt remove libreoffice-qt5

it works for me; so there is no need to remove and to reinstall LibreOffice;

In my LibreOffice, under Help > About LibreOffice dialog box: the VLC is now not qt5 any more, but gtk3

Remove and reinstalling LibreOffice didn’t solve the blank problem. Then I tried installing kf5 and uninstalling qt5 and it worked like magic. It also made the LibreOffice Writer look better.

Worked for me!

The 2 sudo commands -
sudo apt install libreoffice-kf5
sudo apt remove libreoffice-qt5

from above worked for me also, but may I offer a warning to newbies from my experience. Make sure you exit from your current flawed LibreOffice write session, before you re-try to print.
When I issued the 2 sudo commands initially, I still observed my problem of a blank page only being emitted when I had attempted to print an entire .odt document. I made the mistake of not exiting from my LibreOffice write session from which could not print. I suspected my error and inspected with help > about LibreOffice dialog box and found the VLC was still connected to ‘qt5’. I exited that session and launched Libre Office Write again, making no other changes. A second inspection of 'help > about LibreOffice showed the VLC pointed to the desired ‘qtk43’. I issued another print in this new session and my document printed in its entirety, Lesson:Removal of qt5 awaits release by running images

I followed the given solutions and I still have the same problem. Lubuntu 20.10. The second time I uninstalled and reinstalled, I made sure to install the qt5 package of Libre Office first, but to no avail; I still get blank PDF’s, and that is both in printing to a file and export PDF ways; same result.
UPDATE: Also did the install kf5, remove qt5, and still getting same result; blank PDF. By the way, when I open the PDF, it shows me the blank PDF for a second, then the window closes. No error message or anything, just silently closes.

This is not a answer to the question but another comment, that a solution doesn’t work for you. And please notice that the answer was related to Ubuntu 20.04 based systems and not to an daily build of upcoming 20.10 releases. Hence you applied a solution to a system, which wasn’t targeted by the solution.

I’m sorry; it’s my first time here, and when I tried to post my comment the interface read “Post Answer”, for some reason, and there seemed to be no way of persuading the interface to switch to a comment. Regarding the version of Lubuntu, again I did not know it mattered so much; and it was actually 20.04 until yesterday, when after an autoupdate I saw “version 20.10” flash on the screen for a fraction of a second; I was never able to verify whether it is actually changed. I’m sure there’s some arcane shell command to find out in unix, but I’m new to unix (or posix, or whatever). I can tell you for sure my version was 20.04 when this problem started; and I’ve already followed the solutions presented here 3 times with no success.

Make sure you have libreoffice-gtk3 installed, and libreoffice-qt5 uninstalled.

With the LUbuntu distribution 20.04.1 LTS (LXQt 0.14.1), if libreoffice-qt5 is installed, LibreOffice will use it. And this apparently kills printing and PDF exports. After I unistalled libreoffice-qt5, printing and PDF export from under LibreOffice started to work I think OK.

I did not have to reinstall the whole LibreOffice for that fix to work. My LUbuntu distribution 20.04.1 LTS was an upgrade from the previous 19 LUbuntu. No particular tweaks/tricks. After 20.04.1 LTS upgrade, LibreOffice, as others noted, stopped printing or exporting PDFs correctly.

This one works for me. The only thing I had to do was:

sudo apt purge -y libreoffice-qt5

Many thanks, J.

It’s work! Thanks!