We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

How do I get rid of black horizontal lines and prevent them from being generated when I hit "enter"?

asked 2021-04-26 00:25:32 +0200

createdamadman gravatar image

updated 2021-04-26 02:34:18 +0200

Every page online about this says to go to "Format > Paragraph > Borders", and just select the box with no lines/click "none". This doesn't work at all. Is there a different way to get rid of these lines?

C:\fakepath\SPAN2.odt

edit retag flag offensive close merge delete

Comments

Are you selecting the paragraphs before applying no border? There is also an autocorrect option to triple dash.


Add Answer is reserved for solutions.Please, click edit below your question to add more information.

LeroyG gravatar imageLeroyG ( 2021-04-26 00:34:37 +0200 )edit

Yes, I've tried highlighting the paragraph with the lines, just the lines themselves, and the entire document to get rid of all of them. Nothing works.

createdamadman gravatar imagecreatedamadman ( 2021-04-26 00:36:02 +0200 )edit

Do you have underline set on all your text?

It might be easiest if you can share a sample document with the effect showing. You can click edit just below your question, then click the paperclip icon to upload a .odt. Cheers, Al

Earnest Al gravatar imageEarnest Al ( 2021-04-26 02:26:21 +0200 )edit

Okay. I have uploaded the document. Please note that a lot of the text is actually screenshot images. It is on page 5 where I use regular text and start having problems with the lines. I created the initial lines by using a series of hyphens which changed to a solid line upon pressing enter. Ever since, I cannot press enter without it generating a new line. I can delete the lines with backspace/delete but they just come back when I press enter again.

createdamadman gravatar imagecreatedamadman ( 2021-04-26 02:37:14 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2021-04-26 07:48:51 +0200

You can place your cursor in the line and just hit Ctrl+M.

The Format > Paragraph, Borders tab also works for me. You've to click the Set no borders icon in the Line Arrangement section, top left of the tab, Presets line.

If you don't want this to happen anymore, in Tools > AutoCorrect > AutoCorrect options, Options tab, uncheck the entry Apply Border.

To show the community your question has been answered, please tag the best answer (), and/or vote for any helpful answer. Else, please edit your question to add information (answers are for solutions only).

edit flag offensive delete link more

Comments

The Format > Paragraph, Borders tab still doesn't work for me. In fact, the "set no borders" is always already selected even though this does nothing to get rid of the lines. However, the Ctrl + M seems to have worked, so I will just do that if needed in the future. Thanks.

createdamadman gravatar imagecreatedamadman ( 2021-04-26 23:37:07 +0200 )edit

@createdamadman, actually, you have to click the set no borders "button", then you should see the bottom border disappear in the preview area. Then click OK button of course.

By default, that set no borders button seems to be activated but it is a glitch IMHO.

Hagar Delest gravatar imageHagar Delest ( 2021-04-27 07:25:54 +0200 )edit
0

answered 2021-04-26 08:43:39 +0200

ajlittoz gravatar image

The hyphens have been interpreted by AutoCorrect as a request to create a bottom border. This added the border as a direct formatting directive.

In Writer, formatting is applied in three layers:

  • the deepest is paragraph style
  • the middle one is character style
  • the shallowest is direct formatting

Each layer is independent from each other and overrides those deeper.

The problem with direct formatting is: once added, it remains in effect until explicitly cleared with Ctrl+M.

When you press Enter, your new paragraph inherits the direct settings layer of the previous paragraph.

To avoid this, disable AutoCorrect (which was implemented to mimic some features of M$ Word, but this is more harmful than useful because many transformations happen unbeknownst to user) and format exclusively with styles (which when customized are fully under your control). See the Writer Guide for an introduction.

Obviously, your document is direct formatted. You'll enter into trouble when you reach the proof-reading/formatting adjustment step because you'll have to track each formatting directive you've introduced without any guarantee about consistency across the book.

Your text is a mix of Text Body and Default Paragraph Style (which should not be used for text; it is a "technical" style to set default for all others). You use Heading 2 apparently for its visual effects while this style is part of the chapter/sub-chapter/sub-sub... hierarchy. Don't use Shift+Enter (line break) for Enter (paragraph break): they are not the same and will change your document structure with adverse effect on formatting. Don't use empty paragraph to space vertically your text; use the spacing property of paragraph style instead.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-04-26 00:25:32 +0200

Seen: 41 times

Last updated: Apr 26