We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

LibreOffice 7.0: Paste Table Cells from Calc to Writer Does Nothing

asked 2021-06-09 21:37:20 +0200

SSJGQ gravatar image

updated 2021-06-10 13:40:13 +0200

This has always been a problem, but after upgrading now I can't paste the cells at all. In previous versions I had to always select and paste twice, as the first paste changed the cell selection (i.e. it selected other cells and pasted into them instead).

Now, however, when pasting cells from Calc into a Writer table the screen simply flashes and nothing happens. Not even an entry in the undo history.

Any ideas on how to fix this behavior?

Windows 10, LibreOffice 7.0.6.2

EDIT: Here are example Calc and Writer files that show the behavior for me. I'm curious if these files show any of you the same inability to copy/paste.

C:\fakepath\Test Spreadsheet.ods

C:\fakepath\Game xxx Positions.odt

edit retag flag offensive close merge delete

Comments

Clipboard issues seem to affect only some users and in different ways, see tdf#62196. Potentially fixed by tdf#140813 resolved in 7.1.3 version according to bug report. If you are happy to try out Latest version it might be worth it for you.

Do you have a clipboard manager? Try turning it off and seeing if that helps.

Try copying using a different method e.g. Ctrl+C instead of clicking icon or menu; or clicking icon instead...

Try copying twice.

Earnest Al gravatar imageEarnest Al ( 2021-06-09 23:57:46 +0200 )edit

Do you mean, what is shown here

image description

does not work for you? If yes - do you use a clipboard manager?

Opaque gravatar imageOpaque ( 2021-06-09 23:57:48 +0200 )edit

@Earnest AI -- I am running a clipboard manager (clipboardfusion). Turning it off does not change the behavior.

@Opaque -- I am trying to paste Calc cells into cells in an existing table in Writer. I am able to paste Calc cells into a new table in Writer, which I can then copy and paste into the existing table (my current workaround). Pasting the cells directly from Calc does nothing.

I should point out that I when I select the cells (in Writer) and paste into them (which does nothing), the selection changes from the cells to the text in the cells.

SSJGQ gravatar imageSSJGQ ( 2021-06-10 00:09:34 +0200 )edit

I am trying to paste Calc cells into cells in an existing table in Writer.

How do you select(copy the cell and its contents exactly?

Anyhow - for me that works with Copy & Paste from a calc table into an existing Writer table as well by the same method as shown above.

Opaque gravatar imageOpaque ( 2021-06-10 00:13:10 +0200 )edit

Clipboardfusion does have issues in Calc, see question 151164. Uninstalling it is probably best option, especially as it might have unwanted effects elsewhere.

If you really cannot manage without a clipboard manager (after uninstalling) you try using the built-in Windows Clipboard History. Start menu > Settings > System > Clipboard, turn on Clipboard History. Note that this, too might cause problems, but I activate this from time to time without problem on Win 10 and 7.0.6.2

Earnest Al gravatar imageEarnest Al ( 2021-06-10 00:17:58 +0200 )edit

To paste from Calc to Writer table, just click in the first cell of the table that the paste should start, then paste.

SSJGQ If I follow your procedure and select all the cells in the table that I want overwritten with new data, and then paste, all the cells are wiped empty except the last cell into which all the data is written.

Earnest Al gravatar imageEarnest Al ( 2021-06-10 00:38:51 +0200 )edit

@Earnest AI If I just click in the first cell it (used to) nests all the cells into that first one. Your method does not work.

Of course, at this point nothing is working. I am not running the clipboard manager, nor am I uninstalling it, as it doesn't seem to be causing the problem. I'm attaching a gif to show the behavior. Note that I try selecting just a spot in the first cell, and then all the cells, and neither method works. However, I can see the paste attempted, but it just disappears. I can also paste into a new table (also shown in gif)

gif here (I don't know how to inline it)

SSJGQ gravatar imageSSJGQ ( 2021-06-10 06:46:28 +0200 )edit

I see

as it doesn't seem to be causing the problem

Here is a possible Clipboardfusion workaround, I think. I am not prepared to test on my computer as I don't want a clipboard manager.

Earnest Al gravatar imageEarnest Al ( 2021-06-10 07:49:15 +0200 )edit

@Earnest AI If you wanted evidence, I uninstalled Clipboardfusion but that changed nothing. I still see exactly the same behavior. Note that the problem only occurs when pasting into an existing table.

SSJGQ gravatar imageSSJGQ ( 2021-06-10 13:11:13 +0200 )edit

In my first comment I said there was a potential fix in LibreOffice version 7.1.3 which is listed in downloads under latest version

Earnest Al gravatar imageEarnest Al ( 2021-06-10 21:08:36 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2021-06-11 00:28:36 +0200

Earnest Al gravatar image

The table in the Writer document appears to have some incompatible formatting that prevents it accepting the paste.

Removing all direct formatting allows a normal paste, or deleting the table and rebuilding the table also fixed the issue.

edit flag offensive delete link more

Comments

Does this mean that LibreOffice is incompatible with itself?

Astur gravatar imageAstur ( 2021-06-13 15:48:41 +0200 )edit

I was going to see if I could see anything odd inside the file but I'm not confident I would recognise something wrong. It is still bugging me

I initially thought the file might have originated in Word with some sort of write protection for text. I haven't entirely dropped the thought

Earnest Al gravatar imageEarnest Al ( 2021-06-13 22:31:56 +0200 )edit

I had a look inside Content.xml and I'm pretty sure it has been a docx at some time during its history. Astonishing how much rubbish Ctrl+M removes!

Earnest Al gravatar imageEarnest Al ( 2021-06-14 02:17:21 +0200 )edit
0

answered 2021-06-10 08:46:21 +0200

Astur gravatar image
Any ideas on how to fix this behavior?

Even if you include your files with the question, we can probably paste it without any hassle. Certainly when it comes to me, because I use a completely different operating system.

In fact, you would need to transplant a memory dump from your computer here, and preferably teleport the entire computer… Which is not advisable, even if it were possible.

Therefore, it is best if you create a completely new user account on your computer (after all you can delete it), on which you run LibreOffice without extensions and other changes, to see if the unpleasant effect recurs (open the graphic in a new window to see it in its original size):

image description

If it works, add new changes, starting with the least problematic, e.g. changing the default icon style. The change causing the undesirable effect should be removed in the installation that you use on a daily basis.

If did not work, the problem is with the installation. Remove LibreOffice completely and clean up leftovers in its directory. Restart the system and reinstall it from files downloaded from libreoffice.org. If that doesn't work, disable individual services provided by Windows in the new account until the effect wears off. For example, the built-in clipboard manager.

Please comment on my statement to let me know if any of what I wrote had any effect.


The best thanks for the answer is clicking on the picture vote so that it turns green thx. This may take a while.

edit flag offensive delete link more

Comments

@Astur Nothing changed at all. Uninstalled Libreoffice completely and reinstalled. Used new account. I disabled the clipboard services in the new user account and that still changed nothing.

SSJGQ gravatar imageSSJGQ ( 2021-06-10 13:32:40 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-06-09 21:37:20 +0200

Seen: 32 times

Last updated: Jun 11