We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

"Save As" Problem

asked 2021-06-10 15:23:51 +0200

KenDixon gravatar image

updated 2021-06-10 16:04:03 +0200

Opaque gravatar image

As a writer, I'm constantly creating new documents and saving them to one of several client folders. But sometimes LibreOffice tries to save them in a folder called "218" instead. How can I make that stop?

[Edit - Opaque] removed tags "as" and "218"

edit retag flag offensive close merge delete

Comments

Could it be you are using Linux (Ubuntu or one of its derivatives) and a snap version of LibreOffice?

Anyhow: Please provide information from Help -> About LibreOffice and the full path of your folder 218.

Opaque gravatar imageOpaque ( 2021-06-10 15:53:08 +0200 )edit

Thanks for your response. I downloaded LibreOffice 7.1.3.2 via the Zorin distro of Linux.

The "Save As" path shown is "home/kentraco/snap/LibreOfffice/218". But under "Home", there is no "kentraco" folder.

I should point out that this problem occurs intermittently. I see no pattern to it.

KenDixon gravatar imageKenDixon ( 2021-06-10 16:10:40 +0200 )edit

But under "Home", there is no "kentraco" folder.

Home vs /home (Linux is case sensitive and the full path look like to be: /home/kentraco/snap/LibreOfffice/218).


I'm pretty sure that directory 218 does exist (this is typical for snap installations of software, which includes LibreOffice as well) and the only advice: Take care on folder selection, when it comes to Save As. May be you could set a customized document path in Tools -> Options -> LibreOffice -> Paths (I got no snap installation of LibreOffice on any of my test system, so can't check for you). Though it is of course at your own discretion, which type of packing you use, but in your case I'd prefer to use Ubuntu's LibreOffice PPA, since ZorinOS is an Ubuntu derivative.

Opaque gravatar imageOpaque ( 2021-06-10 16:19:09 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-06-10 17:50:18 +0200

Opaque gravatar image

updated 2021-06-10 18:05:07 +0200

Hello

set a new path to My Documents in Tools -> Options -> LibreOffice -> Paths which by default is set to $HOME/snap/libreoffice/218 - see the following screenshot from a fresh ZorinOS 15 installation using snap version of LibreOffice.

image description

This causes to select $HOME/snap/libreoffice/218 if you use Save As on a new document.

And now I understand your use of term HOME, which is one of the "facts-hiding" features of GNOME desktop manager, which is why I don't like it. Open a terminal and use commands echo $HOME,ls -l,pwd and you get what your system really has.

Hope that helps.

edit flag offensive delete link more

Comments

I made the edit you suggested, changing the path to the folder I use most often. That seems to have solved the problem.

KenDixon gravatar imageKenDixon ( 2021-06-10 17:59:01 +0200 )edit

If the answer works for you, please consider to click the check mark (✔) next to the answer. (That's the way to indicate a correct answer, there is no need to close a question). Thanks in advance ...

Opaque gravatar imageOpaque ( 2021-06-10 18:06:28 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-06-10 15:23:51 +0200

Seen: 24 times

Last updated: Jun 10