Ask Your Question
0

Disabling fractions so that typing 3/4 gives me .75 or 3/04/14 [closed]

asked 2014-03-22 21:51:22 +0100

libreNoob gravatar image

When I type in 3/4 in libreoffice calc (or 1/2, 1/4), its displays ¾ (a symbol/icon of "3/4" as a fraction). I would prefer that it convert 3/4 to a more appropriate type for the cell. So if the cell is a date cell, I would prefer it display "03/04/14". Or if the cell is a numeric cell, I prefer it display ".75".

How do I configure Libre Calc to do that?

Thanks..

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-20 08:52:56.945884

1 Answer

Sort by » oldest newest most voted
1

answered 2014-03-22 22:25:01 +0100

Mark12547 gravatar image

If there is an undesired auto-correct, hit Ctrl+Z immediately. In some cases you may have to hit Ctrl+Z twice (e.g., typing 1/2/ will immediately change 1/2 to ½ so the cell will show ½/, first Ctrl+Z removes the /, the second Ctrl+Z will change ½ back to 1/2, and then you can hit / to get 1/2/ and you can then type in the year).

To stop auto-correct on 1/4, 1/2, and 3/4 only, but have corrections for other key combos and common transpositions, go into Tools, AutoCorrect Options, "Replace" tab, move highlight bar to 1/2, and hit the Delete button, and repeat for 1/4 and 3/4.

Or you can stop all auto-corrections by going into Tools, AutoCorrect Options, "Options" tab, and uncheck "Use replacement table".

Without auto-correction or undoing an auto-correction with Ctrl+z, the 1/2 will be interpreted as a date (at least with the US locality).

To get 1/2 to come up as 0.5, you can type =1/2 followed by a tab, space, or Enter.

The "=" tells Calc that what you type next is part of a formula, and the formula will be put into the cell (so going back to the cell will show =1/2 in the input line).

edit flag offensive delete link more

Comments

unfortunatly autocorrection is performed even if no 1/2, 1/4, 3/4 item in replacement table

paolobenve gravatar imagepaolobenve ( 2015-05-18 18:57:27 +0100 )edit

@paolobreve: same here, autocorrection is performed no matter what's in the replacement table. Here's what happens to me on LibreOffice Calc 5.4.5.1: if a cell is of type number, I enter 3/4 and a space, then Ctrl-Z and ¾ is converted to a date 03/04/18; if the cell is of type text, I enter 3/4 and a space, then Ctrl-Z and ¾ is converted back to the original 3/4. Note that the space is necessary, otherwise Ctrl-Z will clean the cell.

fedelibre gravatar imagefedelibre ( 2018-03-12 14:24:14 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-22 21:51:22 +0100

Seen: 2,748 times

Last updated: Mar 22 '14